NoMachine version 7 available for download

Forums / General Discussions / NoMachine version 7 available for download

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #30771
    AvatarBritgirl
    Keymaster

    Hey NoMachiners! Come and download version 7, you’re going to love it! A redesigned user interface bringing you some cool refinements we hope you’ll appreciate, enhancements for those who use our Terminal Server products, Wake-On-Lan, and loads more.

    Get the details here:
    https://www.nomachine.com/what-s-new-in-nomachine

    and the release notice with the list of full features and fixes here:

    https://www.nomachine.com/SU11R00214

    Enjoy 🙂

    #30781
    AvatarThierry
    Participant

    I’m sorry to say that the USB redirection (macOS Big Sur local towards Win10 distant) does still not work for me.

    The /Library/Application Support/NoMachine/Extensions/nxusbvhci.kext kernel extension is not loaded.

    When I try manually sudo kextload -vvv “/Library/Application Support/NoMachine/Extensions/nxusbvhci.kext”

    I get: Password:

    Executing: /usr/bin/kmutil load -p /Library/Application Support/NoMachine/Extensions/nxusbvhci.kext

    Error Domain=KMErrorDomain Code=27 “Extension with identifiers com.nomachine.kext.nxusbvhci not approved to load. Please approve using System Preferences.” UserInfo={NSLocalizedDescription=Extension with identifiers com.nomachine.kext.nxusbvhci not approved to load. Please approve using System Preferences.}

    The only problem is that in System Preferences, it does not show up and thus can’t be approved.

    Huge disappointment here after being so excited about version 7. But I’m sure that there is a fix. Please let me know!

    #30827
    AvatarThierry
    Participant

    I’d be very grateful to get an answer. Is the USB sharing problem in macOS Big Sur which I described above still by design (I had hoped that ver 7 would fix this), or is it only my machine which has problems?

    #30830
    AvatarBritgirl
    Keymaster

    Sorry for not responding earlier. This will be available in the next maintenance release.

    #30854
    AvatarBabok
    Participant

    Hey,

    I upgraded it from 6.11.2_1 and now i cannot connect anymore.

    Here the error message on nxerror.log file:

    “main: WARNING! User ‘xxxx’ unable to read file.”

     

    I would appreciate any help

    #30856
    AvatarBritgirl
    Keymaster

    Can you tell us what OS you updated? Can you send us the logs (you send directly to forum[at]nomachine[dot]com or attach here.)

    #30858
    AvatarThierry
    Participant

    “Sorry for not responding earlier. This will be available in the next maintenance release.”

    Still no luck with the just installed 7.0.211 🙁

    nxusbvhci kext can’t still not be loaded (and is still v6.2.18). I’m getting depressed…

    #30859
    AvatarBabok
    Participant

    The free version is installed on linux debian buster 10.7

    Everything was working on 6.11.2_1 with authentification by NX-private-key.

    The client is updated also on Windows 10. When I try to connect I get the error message: Authenfication failed

    #30866
    AvatarBabok
    Participant

    I found by myself, here how:

    You need to modify permissions  in ~/.nx/config/authorized.crt

    Before nx was able to read this file with owner ( root root ) and permissions set to 0600

    Now with this latest update you have to modify the owner with the user profile and permissions set to 0600

     

    #30881
    AvatarBilbotine
    Keymaster

    Hi Babok and Thierry,


    @Babok
    , thank you for noticing it, it should indeed work like that.


    @Thierry
    , we already made small releases, with some bug fixing. We expect this bug fix to be published within two weeks.

    #30910
    Avatarjjgalvez
    Participant

    Just installed 7.0.211 on Arch gnome and the tray icon no longer comes on at start. I have to start player first manually. This worked with 7.0.209.

    #30949
    AvatarGega
    Participant

    Hi jjgalvez,
    In order to investigate we need you to collect and send logs to us. This article shows how to collect logs: https://www.nomachine.com/DT10O00163

    In your case it’s enough to collect server side logs.

    Please submit them to forum[at]nomachine[dot]com putting the title of your topic as the subject.

    #30981
    Avatarjjgalvez
    Participant

    Hi @Gega,

    thank you for the reply.  I believe some of the issues I was having may have been because of a misconfiguration on my end. After some complete removal and reinstall it seems to be working. I will hold off until the next release in a few weeks and post back if I continue to have issues.

    Again thanks

    #31017
    AvatarBritgirl
    Keymaster

    Can I ask anyone who wants to report an issue with the most recent version to open a new topic so issues are easily tracked. This will now be closed. Thanks!

Viewing 14 posts - 1 through 14 (of 14 total)

This topic was marked as solved, you can't post.