NoMachine Workstation: new virtual desktop fails

Forums / NoMachine for Linux / NoMachine Workstation: new virtual desktop fails

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #27494
    Avatardrichman
    Participant

    I’m trying NoMachine Workstation Evaluation 6.10.12 on Ubuntu 16.04 LTS, connecting to it with 6.10.12 on Mac OS X (Catalina, 10.15.4), and testing the ability to connect to different user accounts on this shared Ubuntu workstation.

    When I connect to an account that is currently active and displaying on the Ubuntu machine, I see the option to launch the physical display, and it works fine.

    When I connect to an account that’s not active, and can be logged in or not, I see the options to create a new virtual desktop or create a new custom session, and I try to create a new virtual desktop. It opens a black screen for a few seconds and then kicks be back to the connection screen.

    If I switch the active account at the Ubuntu machine it’s the opposite–in other words, I can remotely launch the physical desktop of the account that’s displaying but not the virtual desktop of an account that’s not displaying.

    I tried these solutions to no effect:

    https://www.nomachine.com/TR03M05061 (Black screen occurs when connecting virtual desktops on Ubuntu 14.04)

    https://www.nomachine.com/AR09L00814 (A black screen is displayed when running virtual desktops on Unity 3D or GNOME 3 and proprietary drivers)

    I reproduced the problem while taking debug-level logs on server-side, please find attached. Thanks for your help.

    #27525
    Avatarshiba
    Participant

    Hi!

    We cannot reproduce such problem on the fresh installed Ubuntu 16.04 with default UNITY. Could you tell what graphical environment are you using? Please give us the output of

    /usr/share/xsessions

    Could you also check what is your DefaultDesktopCommand in /usr/NX/etc/node.cfg

    We have:
    DefaultDesktopCommand “/etc/X11/Xsession ‘gnome-session –session=ubuntu'”

    Please check our article https://www.nomachine.com/AR04K00667

    #27546
    Avatardrichman
    Participant

    Contents of /usr/share/xsessions:

    -rw-r–r–   1 root root   204 Aug 22  2016 ubuntu.desktop

    Based on the article, section 2.1, I checked:

    grep ^Exec /usr/share/xsessions/ubuntu.desktop

    Exec=gnome-session –session=ubuntu

    And from node.cfg:

    DefaultDesktopCommand “/etc/X11/Xsession ‘gnome-session –session=ubuntu'”

    and I checked that it’s not commented out.

    Do you think I need to pursue one of the approaches in the article, like installing a different environment globally or per-user?

    Thanks again!

    #27599
    Avatarshiba
    Participant

    Could you check again with this command?
    DefaultDesktopCommand "/etc/X11/Xsession ‘gnome-session --session=ubuntu'"

    If that doesn’t help, send us logs from server side. Please find the instructions here: https://www.nomachine.com/DT10O00163#1. You can send them to forum[at]nomachine[dot]com

    #27791
    AvatarBritgirl
    Keymaster

    drichman, we received your logs, thank you. Unfortunately, you didn’t enable debug before reproducing the problem.

    https://www.nomachine.com/DT10O00163#1.1

    Please enable debug as per the instructions on the server-side, reproduce the problem, gather the logs and then send them to us as you did before.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.