NoMachine 4, remote access involves unlocking my desktop

Forums / NoMachine for Linux / NoMachine 4, remote access involves unlocking my desktop

Tagged: ,

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #306
    yossarianuk
    Participant

    Hi

    I have previously used NX server (NX 3.x) to connect to my work PC for working from home.

    I use KDE on my Work pc but I had previously also installed LXDE on it purely for my NX connection from home (as its lighter and to not conflict with my normal desktop..)

    The issues with NoMachines 4.x are

    – I can no longer choose which desktop I login into remotely I just use the one the user is connected to.

    – To access my work PC now I have to unlock my user session to connect – this means anyone in the Office could use my PC and see what i’m doing…. Previously (with nx 3) my KDE session would be locked and I would login the same user via the LXDE desktop – this meant no one in the office could use my unlocked session/ see what I was doing.

    Is it possible to get round these issues anyway ?

    #310
    yossarianuk
    Participant

    Also if someone in the office moves my mouse and start (I work with some jokers…) that is also going to be annoying.

    Is there a way to login to a different desktop/user and im a way where my physical pc is not needed to be unlocked (like NX 3.x) ?

    I think if I left the desktop unlocked (in order to use NX) that would also break PCI ISO compliance.

    #316
    titan
    Participant

    Security risk? Remote access now involves unlocking my desktop

    NoMachine now works as traditional remote access software, which is what Mac, Windows and Linux users expect, as long as these users are looking for a remote access software. NoMachine should provide the option of blanking the screen and locking the keyboard and mouse while an unattended computer is engaged in a connection. We are working on this. It turned out to be a bit trickier than one would have expected. If the computer is on a table where there are others that walk and see what is displayed, you should probably look for a terminal server that the free NoMachine 4 is not.

    I can no longer choose which desktop I login into remotely I just use the one the user is connected to.

    The Workstation and all the Terminal Server versions work as terminal servers, by creating sessions running in the background. These are terminal servers, intended for the enterprise market. The free 3 worked as a terminal server limited to 2 users. This functionality is no longer available in the free version.

    Is there a way to login to a different desktop/user and im a way where my physical pc is not needed to be unlocked (like NX 3.x) ?

    Yes, install the Workstation edition or run a virtual X server as explained here:

    http://www.nomachine.com/AR10K00710

    We have added a new configuration key to the server in the next update, so that users can specify to which display NoMachine must connect. You can run a virtual X server on :1 and tell NoMachine to connect to it, rather than the physical display on :0. This :1 will run in the background, so others can’t see what is displayed. This is the way VNC also works, so, free for free, you get a widely better software for the same price.

    #366
    yossarianuk
    Participant

    HI

    I did try following the guide

    http://www.nomachine.com/AR10K00710

    I logged into the NX server (NoMachines 4) and stopped lightdm

    It seemed to work o.k

    For Step6 I used

    DISPLAY=:0 /etc/X11/Xsession startlxde &

    – However NoMachines client could not see any sessions.

    I also tried

    DISPLAY=:0 /etc/X11/Xsession lxsession &

    Any ideas of how to make it work or at least troubleshoot why I cannot see any sessions.

    Regards

    #709
    Dan25
    Participant

    Did you get errors when following those steps in the article?

    I logged into the NX server (nomachines 4) and stopped lightdm

    You shouldn’t have to stop lightdm.

    DISPLAY=:0 /etc/X11/Xsession startlxde &

    Try substituting DISPLAY=:0 with DISPLAY=:1. It’s better to have the virtual desktop running on a different display to :0.

Viewing 5 posts - 1 through 5 (of 5 total)

No further information provided by the user for more than 10 days. This topic was marked as closed, you can't post.