NoMachine/Gnome Desktop not working on E2C CentOS 7 instance

Forums / NoMachine for Linux / NoMachine/Gnome Desktop not working on E2C CentOS 7 instance

Tagged: 

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #8399
    pvn
    Participant

    After creating an “CentOS 7 (x86_64) with Updates HVM” instance i take the following installation/configuration steps.

    yum groupinstall gnome-desktop internet-browser

    # Install nomachine on server
    sudo -s
    cd /var/tmp
    wget http://download.nomachine.com/download/4.6/Linux/nomachine_4.6.16_1_x86_64.rpm
    rpm -ivh nomachine_4.6.16_1_x86_64.rpm
    rm /var/tmp/nomachine_4.6.16_1_x86_64.rpm
    exit

    # Install Xvfb
    sudo yum install xorg-x11-server-Xvfb

    # Start nxserver headless for user oracle
    sudo -s cat > /etc/init.d/nxheadless << EOF2
    #!/bin/bash

    export NOMACHINE_USER=oracle

    case \$1 in
    ‘start’)
    # Create a random cookie (a 16-hex-digit string)
    COOKIE=\$(ps -ef | md5sum | cut -f 1 -d ” “)
    # Create Xvfb authority file
    AUTHFILE=\$HOME/Xvfb-0.auth
    xauth -f \$AUTHFILE add :0 MIT-MAGIC-COOKIE-1 \$COOKIE
    # Add the cookie to the user’s authority file
    xauth add :0 MIT-MAGIC-COOKIE-1 \$COOKIE
    # Run Xvfb with 24-bit screen depth
    Xvfb :0 -auth \$AUTHFILE -screen 0 1440x900x24 &
    # Run the desktop environment
    export DISPLAY=:0
    nohup /etc/gdm/Xsession gnome-session &
    # Restart the NoMachine server
    /usr/NX/bin/nxserver –restart
    ;;
    ‘stop’)
    # kill Xvfb
    ps -ef | grep “Xvfb :0” | awk ‘{ print “kill -9 ” \$2 }’|bash
    # remove lock
    rm -f /tmp/.X0-lock
    # Restart the NoMachine server
    /usr/NX/bin/nxserver –restart
    ;;
    *)
    echo “usage: \$0 {start|stop}”
    exit
    ;;
    esac
    exit
    EOF2

    chgrp root /etc/init.d/nxheadless
    chmod 750 /etc/init.d/nxheadless

    echo “# Create symbolic links to run-level scripts”
    ln -s /etc/init.d/nxheadless /etc/rc.d/rc0.d/K01nxheadless
    ln -s /etc/init.d/nxheadless /etc/rc.d/rc3.d/S99nxheadless
    ln -s /etc/init.d/nxheadless /etc/rc.d/rc5.d/S99nxheadless

    Also the private/public key is set correctly for a new created user ‘oracle’.
    I am able to connect successfully to the instance using the NoMachine client using an SSL tunnel.

    Only the desktop does not start and only a black screen is shown.
    I do not see any related errors in /var/log/messages or nxserver seems to start fine.
    After a while the error “A problem has occurred and the system can’t recover. All extensions have been disabled as a precaution.”

    Any ideas, hints, tips,….. solutions?

     

    Cheers,

    Peter

     

    #8512
    Britgirl
    Keymaster

    Try the latest packages of version 5 that we just released and let us know if you’re still having problems. This version has a feature specifically for headless Linux servers https://www.nomachine.com/FR10L02842.

Viewing 2 posts - 1 through 2 (of 2 total)

This topic was marked as solved, you can't post.