Not able to connect NX server via ssh protocol

Forums / NoMachine for Linux / Not able to connect NX server via ssh protocol

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #7516
    rajeev
    Participant

    Hi Gentlemen,

    I have installed NX server 4.6.4 on RHEL 7 and the client is hosted on windows box which is 4.5. From windows machine the linux box is only accessible through ssh port 22. I am very new to NoMachine and unable to understand server configuration to use ssh tunnel.

    I have created a connection on client side using ssh protocol with key authentication. But, I am getting an error “The connection to the server was lost” as soon as the passphrase is entered.

    Please find the client log below(for reference):

    Info: Connection to 52.xx.xx.xxx port 22 started at 14:20:50 280.933.

    7888 6668 14:20:50 572.933 ClientSession: A valid certificate for this server was found.

    7888 6668 14:20:53 396.933 Encryptor/Encryptor: ERROR! Authentication failed.

    7888 6668 14:20:53 396.933 Encryptor/Encryptor: ERROR! Using key passphrase failed in context [A].

    Error: Using key passphrase failed in context [A].

    7888 6668 14:20:53 396.933 Channel/Channel: WARNING! Runnable DaemonReader failed for FD#1452.

    7888 6668 14:20:53 396.933 Channel/Channel: WARNING! Error is 1, ‘Operation not permitted’.

    7888 1716 14:20:53 397.933 Connection: Connection at 0x042c0a88 failed.

    7888 1716 14:20:53 397.933 ClientSession: Runnable at 0x042c0a88 caused the session at 0x0104db08 to fail.

    7888 1716 14:20:53 397.933 ClientSession: Failing reason is ‘The connection to the server was lost’.

    7888 8844 14:20:53 397.933 DaemonClientApplication/DaemonClientApplication: WARNING! Session terminated abnormally.

    7888 8844 14:20:53 397.933 DaemonClientApplication/DaemonClientApplication: WARNING! Error is 1, ‘Operation not permitted’.

    Warning: Connection to 52.xx.xx.xxx port 22 failed at 14:20:53 397.933.

    Warning: Error is 1, ‘Operation not permitted’.

     

    #7635
    barpa
    Participant

    Hello, it seems that provided passphrase is not matching the private key. Check out, in advanced options of the connection, if proper private key is selected. In edit dialog of the connection check ‘Reset saved preferences and password’ checkbox and try to connect again.

    If this will not help, we can send you a debug library to check the issue.

Viewing 2 posts - 1 through 2 (of 2 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.