Not able to run Linux GUI on top of NoMachine using AWS EC2 instance

Forums / NoMachine for Linux / Not able to run Linux GUI on top of NoMachine using AWS EC2 instance

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #5344
    Avatardinesh
    Participant

    I have launched 64-bit RHEL6.5 ec2 instance. I have done below steps:

    # yum -y groupinstall “Desktop” “Desktop Platform” “X Window System” “Fonts”
    In /etc/yum.conf added below line

    group_package_types=default mandatory optional

    group_package_types=default mandatory optional

    #yum -y groupinstall “Legacy X Window System compatibility”

    Open /etc/inittab using a text editor and change following line:

    id:3:initdefault: to id:5:initdefault:

    # init 6

    #rpm -ivh nomachine_4.3.30_1_x86_64.rpm

    #I have added security port 4000 in Security group of instance for custom tcp rule.

    Then i have try to connect my EC2 instance through NoMachine. But i am getting below error

    Warning: Error is 1, ‘Operation not permitted’.
    31008 8440 11:18:22 747.182 Connection: WARNING! Ignoring the I/O error and waiting for the daemon error reporting.
    31008 8440 11:18:22 755.179 Connection: Connection at 0x03d44090 failed.
    31008 8440 11:18:22 755.179 ClientSession: Runnable at 0x03d44090 caused the session at 0x02591370 to fail.
    31008 8440 11:18:22 755.179 ClientSession: Failing reason is ‘Authentication failed’.
    31008 8440 11:18:22 759.179 ClientSession: Stopping session at 0x02591370.
    31008 8440 11:18:22 769.185 Connection: Stopping connection at 0x03d44090.
    31008 8440 11:18:22 769.185 ClientDaemonConnector: Stopping the current connection.
    31008 8440 11:18:22 773.183 Connection: Stopped connection at 0x03d44090.
    31008 8440 11:18:22 787.181 ClientSession: Stopped session at 0x02591370.

    #I have installed NoMachine_4.3.30_1 package in windows 7. And i am using PPK key file for authentication. Also i have attached session log.

    #5352
    Avatarreza
    Moderator

    Are you trying to connect using NX protocol?

Viewing 2 posts - 1 through 2 (of 2 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.