Not finding physical session or opening virtual session

Forums / NoMachine for Linux / Not finding physical session or opening virtual session

  • This topic has 4 replies, 2 voices, and was last updated 3 weeks ago by jtbr.
Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #35592
    jtbr
    Participant

    I’ve upgraded my server’s version of Linux Mint to 19.3 (based upon ubuntu 18.04), and re-installed NoMachine to the latest 7.6.2-4 (I also upgraded my client on Linux Mint 20.1 to this version of nomachine).

    Now, when I try to log in with NoMachine client, I get this message:

    Cannot detect any display running. Do you want NoMachine to create a new display and proceed to connect to the desktop?

    lightdm is running on the server, and I want to connect to this physical session. Nonetheless, if I answer yes, I am also unable to create a virtual session. I get the error:

    The session negotiation failed.

Error: Cannot create a new display, please contact your system administrator

    I have tried changing the DefaultDesktopCommand in node.cfg to “/usr/lib/cinnamon-session-cinnamon”, to no effect. I then tried to set it to “/usr/bin/gnome-terminal” to see if I could open the cinnamon session manually, and this also fails with the same message.

    (Once lightdm is logged in, I want to access the cinnamon desktop, but as I am remote, I have relied upon NoMachine to log into the physical x session after a reboot. I also couldn’t access the running cinnamon session before I rebooted; same errors, although I have purged and reinstalled NoMachine since the reboot in an effort to get this working).

    I’m at a bit of a loss as to what is happening here, don’t see anything else relevant in the forums, and don’t see anything obvious in the logs (attached, client and server). Any help is appreciated.

    Attachments:
    #35598
    jtbr
    Participant

    reattaching logs

    #35604
    jtbr
    Participant

    trying again to attach logs

    #35606
    kroy
    Contributor

    DefaultDesktopCommand "/usr/bin/cinnamon-session --session cinnamon" should fix the problem with virtual desktop.

    Regarding to physical desktop – we cannot reproduce such problem on Mint 19.3 with LightDM. Is it clean installation of the NoMachine? If it’s update, upgrade or some re-installation – execute following commands:

    sudo /etc/NX/nxserver --addtoredis
    sudo /etc/NX/nxserver --restart

    and recheck. If that won’t help we suggest to remove NoMachine with all config files:

    sudo dpkg --purge nomachine
    sudo rm -rf /usr/NX /etc/NX /var/NX

    and install again newest package.

    #35616
    jtbr
    Participant

    Thank you for your help. Running the following:

    sudo /etc/NX/nxserver --addtoredis

    did the trick. Now I can connect to my physical display again!

    Before I did that, I did try to change the DefaultDesktopCommand as you suggested, but to no avail.
    Perhaps the above command will have fixed that too (?). Nevermind though, what I really need is the physical display.

    Thanks again.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.