NX client could not create the NX directory

Forums / NoMachine for Windows / NX client could not create the NX directory

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #7996
    Avatarsamo_dadela
    Participant

    Hi,

    A problem I have been experiencing with (free) NoMachine_4.6.12_1.exe (I even reinstalled the whole system thinking my windows installation had a problem). This happens on Windows 7 x64.

    I install NX without problem, try it – everything works (even between reboots). Then suddenly, when I login into windows I get:

    NX client could not create the NX directory .Please check for the home’s permissions.

    And on the C:\ I get the following directory (each reboot one):

    C:\M-127.0.0.1-20022-CA8BA2965D2673EF10786F7C72CEF1C1

    C:\M-127.0.0.1-35132-1B309B96CE0B8B54505B09D942C7E93B
    I tried rebooting, disabling the startup of NX services (in NoMachine Service) to no avail. Each time I get that popup (see attached pic) and one new M-127 directory.

    What I suspect is at fault:

    When I installed NX I was connected to my AD domain and logged in as a domain user. But when I moved to another location/network where AD is not available and logged in as the same user, the problem starts happening.

    Any idea?

    BTW: How/where is nxclient (or the program) that displays the pop-up started from? I checked msconfig and it’s not there. Disabling the service in services.msc doesn’t help also.

     

     

    #8008
    AvatarBritgirl
    Keymaster

    It appears you have also opened a support ticket. I advise you to follow the ticket through. That’s because personal information might be exchanged which you don’t wish to be made public. Additionally, there might be issues involved which are outside the scope of the forums. Please send support the complete set of logs to support as they will request https://www.nomachine.com/AR07K00677.

    #8007
    Avatarjkettsjr
    Participant

    I am having exactly the same problem I am posting to see if there is a recommended solution.

    #8012
    Avatarsamo_dadela
    Participant

    Britgirl,

    I have not opened a support ticket – only this post. Maybe someone else had the same problem?

    BTW: Take a look at the error message also:

    – There’s punctuation error – the dot should be followed by a space (and not preceeded). You might fix this as well.

     

    #8022
    AvatarBritgirl
    Keymaster

    Weird, the text content is exactly the same. As a forum user, please submit logs to forum[at]nomachine[dot]com. They will be queued up for investigation. Make sure you use the title of the forum post as your subject.

    #8091
    Avatarpauly_long
    Participant

    I also get the same error message on startup.  It looks like some sort of permissions thing, but I have no idea where to start looking.  And like Samo above, on each restart it creates a new directory.

    I’m attaching screenshots of the error message on start up and the extra directories.

    My environment:

    – Win 7 64 bit

    – NoMachine 4.6.12_1 (Free)

    – Logged on to my machine as a domain user

    #8105
    Avatarreza
    Moderator

    Hi Everybody,

    Issue is under investigation.

    If any from users who experience it is willing to help please submit logs to forum[at]nomachine[dot]com

    #8107
    Avatarpauly_long
    Participant

    Happy to help – which logs?  And from where?

    #8113
    AvatarBritgirl
    Keymaster

    https://www.nomachine.com/AR07K00677

    Both sides (client and server). Submit to forum[at]nomachine[dot]com

    #8362
    AvatarDuckeroi
    Participant

    NX had been running without this issue in version 4.6.4_5. After an upgrade to 4.6.16_1, I had this problem on every attempted start of the application. There are no log files as suggested in the link to submit.

    #8560
    AvatarBritgirl
    Keymaster

    This domain issue will be fixed in the next update of NoMachine 5. Here’s the Trouble Report: https://www.nomachine.com/TR08M05944.

    Please use the “Notify me” to know when a fix is available.

Viewing 11 posts - 1 through 11 (of 11 total)

This topic was marked as solved, you can't post.