NX server does not launch at OpenSuse Tumbleweed boot

Forums / NoMachine for Linux / NX server does not launch at OpenSuse Tumbleweed boot

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #31409
    Eragontux
    Participant

    Hi.

    The way to launch the nx server is no longer compatible with the new version of opensuse tumbleweed 20210118. The nxserver works normally but the service must be launched manually. I installed the version ‘nomachine_7.0.211_4_x86_64.rpm’ and it doesn’t solve the problem. Yast Services Manager has the following error: Configuration writing failed: It was not possible to set ‘nxserver’ to start as at startup. Would you like to continue editing? Does anyone have a solution for this?

    #31494
    zaq
    Contributor

    Hello Eragontux

    We weren’t able to reproduce the problem in our laboratory.

    Could you send output from this commands:

    /etc/NX/nxserver --version

    ps aux | grep nx

    systemctl status nxserver

    sudo systemctl restart nxserver

    and packed log directory:

    /usr/NX/var/log

    to forum[at]nomachine[dot]com.

    Do you see the error in YaST2 GUI, pls check attached image.

    Attachments:
    #31506
    Eragontux
    Participant

    Hi Zaq.

    Below the output of the commands:

    vento:/home/eragontux # /etc/NX/nxserver –version
    NoMachine – Version 7.0.211

    vento:/home/eragontux # ps aux | grep nx
    eragont+  3407  0.1  0.3 1410504 50508 ?       Sl   13:22   0:33 /usr/NX/bin/nxplayer.bin
    nx       16571  0.2  0.6 1788236 89064 ?       Sl   20:52   0:01 /usr/NX/bin/nxserver.bin root 1 --daemon
    nx       16618  0.0  0.0 399528  8752 ?        Sl   20:52   0:00 /usr/NX/bin/nxd
    root     16647  0.0  0.0  13792  8508 ?        S<   20:52   0:00 /usr/NX/bin/nxexec --node --user eragontux --priority realtime --mode 0 --pid 46 eragont+ 16652  0.0  0.5 1684484 71904 ?       Snxnode.bin eragont+ 16680  0.0  0.2 1462136 39596 ?       Sl   20:52   0:00 /usr/NX/bin/nxclient.bin --monitor --pid 1322 root     23753  0.0  0.0   6204  2336 pts/1    S+   21:03   0:00 grep --color=auto nx vento:/home/eragontux # systemctl status nxserver ● nxserver.service - LSB: Starts and stops the NoMachine NX Server. Loaded: loaded (/etc/init.d/nxserver; generated) Active: active (running) since Fri 2021-01-22 20:52:43 CET; 12min ago Docs: man:systemd-sysv-generator(8) Process: 16570 ExecStart=/etc/init.d/nxserver start (code=exited, status=0/SUCCESS) Tasks: 28 (limit: 4915) CGroup: /system.slice/nxserver.service ├─16571 /usr/NX/bin/nxserver.bin root 1 --daemon └─16618 /usr/NX/bin/nxd jan 22 20:52:43 vento systemd[1]: Starting LSB: Starts and stops the NoMachine NX Server.... jan 22 20:52:43 vento nxserver[16570]: Starting NoMachine. jan 22 20:52:43 vento systemd[1]: Started LSB: Starts and stops the NoMachine NX Server..

    The response to the sudo systemctl restart nxserver command was normal.

    I want to remind you that the NoMachine works normally. It is just not possible to have it start automatically during boot. The startup script is present in the /etc/init.d folder but it is not possible to launch it during boot. If I try to launch it with the command systemctl start nxserver the answer is that it is not a native service.

    I have two more machines here with the tumbleweed and the NoMachine installed. In all the NoMachine starts normally except this one. The difference is that this machine we are talking about has a new installation while the others have a long history.

    I think there will be changes made to tumbleweed.

    I have another error that I discovered yesterday, this one exists in all machines. It is not possible to update the nomachine or make other changes, the authentication system of the nomachine refuses the administrator password, it is not possible to authenticate on any machine here.

    That is why I say that possibly with the changes in tumblweed the NoMachine has become incompatible.

    I send 3 snapshots with the sequence on Yast Serviços. The last snapshot says that it is not possible to set the nxserver to be started at startup (Translated)

    #31765
    zaq
    Contributor

    Hello,

    Could you check status of nxserver start mode:

    /etc/NX/nxserver --startmode

    if you get:

    NX> 807 Service NoMachine status is: Manual

    please set as automatic:

    sudo /etc/NX/nxserver --startmode automatic

Viewing 4 posts - 1 through 4 (of 4 total)

This topic was marked as solved, you can't post.