NX Server error: parameter ‘login’ cannot be empty

Forums / NoMachine for Linux / NX Server error: parameter ‘login’ cannot be empty

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #39146
    jkary
    Participant

    Hi Folks,

    I’m running Fedora release 35 (Thirty Five) in headless mode with the rpm ‘nomachine-7.10.1-1.x86_64’.  I’ve been having trouble connecting and I’m seeing this in the logs:

    NXMsg: Sent response message ‘NX> 595 NoMachine server exception: parameter ‘login’ cannot be empty (NXUser::new).’

    getParameters: parameter string is ‘–client=”linux” –session=”%%40nxFrameBuffer” –virtualdesktop=”1″ –geometry=”800×600″ –type=”nxFrameBuffer” –foreignAddres=”127.0.0.1″ –render=”1″ –username=”” ‘.

    Can anyone tell me how and where to set the username parameter?  Also what should this value be?

     

    Thanks

    Jason

    #39300
    Britgirl
    Keymaster

    Try in the server configuration file:

    #
    # When ‘CreateDisplay’ is enabled, specify the display owner and let
    # NoMachine create the new display without querying the user. If the
    # server supports only one concurrent connection, the connecting user
    # must be the display owner set in this key.
    #
    #DisplayOwner “”

    See also this article:

    Connecting to Linux headless machines with NoMachine
    https://kb.nomachine.com/AR03P00973

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.