NX Service not starting

Forums / NoMachine for Linux / NX Service not starting

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #6212
    HenryTheTech
    Participant

    Running Linux Mint 17 and 17.1

    I’ve repeatedly removed / reinstalled the program, and even reinstalled the OS to a clean state.

    After some time, the service just doesn’t auto-start anymore.

    Ideas?

     

    (latest build on both sides)

    #6248
    Britgirl
    Keymaster

    Hi, can you add the extra information here that you emailed in 🙂

    #6299
    HenryTheTech
    Participant

    Hi, Im running the newest version of NX on both systems.  Both are running LM 17  KDE.   Thanks!

     

    The service may be running, sometimes it goes down… But nearly every time the NX service icon in the system tray disappears.

     

     

     

    #6316
    nomar
    Participant

    Hello HenryTheTech,

    We don’t have enough information to help you. Could you send to us output of this command ‘ps -Af | grep nx’ and attach NX logs? Instructions how to collect NX logs are here -> https://www.nomachine.com/AR10K00697.
    Send everything to forum[at]nomachine[dot]com and reference the topic title in your subject.

    Regards

    #6340
    HenryTheTech
    Participant

    Done, thanks!

    #6382
    nars
    Contributor

    Hello HenryTheTech,

    Thank you for sending a logs, however they are not sufficient for us to find the problem.

    Could you please set log level to debug and send to us also your server side $HOME/<username>/.nx directory?

     

    Please:

    – edit /usr/NX/etc/server.cfg, uncomment and set “SessionLogLevel 7”

    – edit /usr/NX/etc/node.cfg, uncomment and set “SessionLogLevel 7”

    – reproduce the problem

    – send to us content of /usr/NX/var/log and $HOME/.nx

     

    Regards.

    #6544
    HenryTheTech
    Participant

    Thank you, I have sent those files.

     

    #6579
    Britgirl
    Keymaster

    Hi, further investigation has identified an issue for which we will be opening a Trouble Report. The topic will be updated with this once it’s public.

    In the meantime execute sudo /etc/NX/nxserver –restart

    and then start your connection to the desktop.

    #6586
    HenryTheTech
    Participant

    The command gets the service back online.

    Thank you 🙂

    #6601
    HenryTheTech
    Participant

    Just in case anyone else has this issue,  the command is actually:

    sudo /etc/NX/nxserver –restart

    #6610
    Britgirl
    Keymaster

    There is a bug I think with showing a double ‘-‘. That is actually what I wrote 😉

Viewing 11 posts - 1 through 11 (of 11 total)

This topic was marked as solved, you can't post.