NX services will not start

Forums / NoMachine Terminal Server Products / NX services will not start

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #4745
    uninick
    Participant

    Hello,

    Using “NoMachine Workstation Subscription – Version 4.2.27” on an Ubuntu 12.04 x86-64 workstation, the nxserver services don’t start

    running “service nxserver start” yields:

    NX> 161 Enabled service: nxserver.

    NX> 162 Disabled service: nxnode.

    NX> 162 Disabled service: nxd.

     

    nxd.log is empty.

    nxerror.log:

    No LSB modules are available.

    No LSB modules are available.

    26677 26686 10:00:45 152.142 DaemonParser/Parser: WARNING! Creating directory ‘/var/NX/nx/.nx’.

    26677 26677 10:01:31 922.121 System/System: WARNING! Child pid 5775 not handled in system at 0x7f726ac357a0.

    No LSB modules are available.

    Unknown option: statusd

    No LSB modules are available.

    No LSB modules are available.

    No LSB modules are available.

    2053 2053 16:40:47 825.593 System/System: WARNING! Child pid 9255 not handled in system at 0x7f1f74b2f7a0.

    No LSB modules are available.

     

     

    nxserver.log:

    2014-09-22 10:22:20 372.712 22928 NXSERVER WARNING! Process (22972) finished with signal ’13’.

    2014-09-22 10:22:20 377.683 22918 NXSERVER WARNING! Cannot check ufw status 2.Please check the ‘nxerror.log’ file for possible issues.

    2014-09-22 10:22:20 378.339 22928 NXSERVER WARNING! Process (22974) finished with signal ’13’.

    2014-09-22 10:22:20 381.027 22928 NXSERVER WARNING! Process (22975) finished with signal ’13’.

    2014-09-22 10:22:20 382.395 22918 NXSERVER WARNING! Cannot add firewall rule for 4000 with ufw command 2. Please check the nxerror.log file for possible issues.

    2014-09-22 10:22:20 382.516 22928 NXSERVER WARNING! Process (22977) finished with signal ’13’.

    2014-09-22 10:22:20 386.838 22918 NXSERVER WARNING! Cannot add firewall rule for 5353 with ufw command 2. Please check the nxerror.log file for possible issues.

    2014-09-22 10:22:20 388.089 22928 NXSERVER WARNING! Process (22979) finished with signal ’13’.

    2014-09-22 10:22:20 390.790 22928 NXSERVER WARNING! Process (22980) finished with signal ’13’.

    2014-09-22 10:22:20 392.402 22928 NXSERVER WARNING! Process (22981) finished with signal ’13’.

    2014-09-22 10:22:20 397.998 22928 NXSERVER WARNING! Process (22982) finished with signal ’13’.

    2014-09-22 10:22:20 400.714 22928 NXSERVER WARNING! Process (22983) finished with signal ’13’.

    2014-09-22 10:22:20 402.182 22928 NXSERVER WARNING! Process (22984) finished with signal ’13’.

    2014-09-22 10:22:20 407.679 22928 NXSERVER WARNING! Process (22985) finished with signal ’13’.

    2014-09-22 10:22:20 410.341 22928 NXSERVER WARNING! Process (22986) finished with signal ’13’.

    2014-09-22 10:22:20 411.848 22928 NXSERVER WARNING! Process (22987) finished with signal ’13’.

    ~

    #4763
    reza
    Moderator

    Please, if you have AppArmor or SELinux enabled disable them and try once again.

    If the problem is still there, please enable logs and send them to issues[at]nomachine[dot]com.

    How to gather debug logs is explained in following article:

    https://www.nomachine.com/AR07K00677

Viewing 2 posts - 1 through 2 (of 2 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.