NX sets incorrect resolution

Forums / NoMachine for Linux / NX sets incorrect resolution

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #4028
    Kevin Donnelly
    Participant

    I am using NX 4.2.25-1 on two stock installs of Ubuntu 14.04, a desktop and a laptop, running KDE 4.13.1.  The laptop (Intel graphics) has a resolution of 1366×768, and appears fine on the desktop (Nvidia graphics), which has a resolution of 1680×1050.  However, when I try to access the desktop from the laptop, NX resets the desktop resolution to 1280×720, and it then becomes impossible to access the whole of the desktop.  Is there any way to force NX to accept the 1680×1050 resolution?  I seem to remember there was a setting for this in versions earlier than 4, but it seems to have disappeared, and although I’ve tried all options of the display buttons I can’t stop it doing this.

    #4035
    Tor
    Contributor

    Hi donnek.

    It appears that you left checked the option “Change the server resolution to match the client when I connect” in the last dialog shown when the session connects, or that the “Resize remote screen” option is enabled. In both cases the remote desktop tries to resize to the requested geometry or, if it is not a supported resolution, to the nearest smaller geometry that in your case may be 1280×720. In order to leave the remote desktop to the native resolution, be sure to disable the options above.
    If you’ve dismissed the dialogs appearing when the session connects, you can either create a new connection or edit the configuration and check the box “Reset saved preferences and password”.

    #4036
    Kevin Donnelly
    Participant

    Cool, Tor – thank you so much.  I reset the connection details, and made sure to leave that box unticked.  Once I upped Quality to the max and set Resolution to 1:1 in Display Settings, everything works perfectly – very nice.  Thanks again.

Viewing 3 posts - 1 through 3 (of 3 total)

This topic was marked as solved, you can't post.