NX won’t work with recent KDE 5.17

Forums / NoMachine for Linux / NX won’t work with recent KDE 5.17

Tagged: 

This topic contains 32 replies, has 15 voices, and was last updated by Avatar adrian.elsener 14 hours, 20 minutes ago.

Viewing 15 posts - 1 through 15 (of 33 total)
  • Author
    Posts
  • #24113
    Avatar
    jnko
    Participant

    /usr/NX/bin/nxserver –version
    NoMachine – Version 6.8.1

    Linux l 5.3.6-arch1-1-ARCH #1 SMP PREEMPT Fri Oct 11 18:28:05 UTC 2019 x86_64 GNU/Linux

    tar.gz packages are fine (at least for me)

    #24063
    Avatar
    jnko
    Participant

    “startkde” has been replaced by “startplasma-x11” in th current version 5.17. However replacing “startkde” with “startplasma-x11″ in /usr/NX/etc/node.cfg” does not work at all. It it not possibe to connect to a NX server running KDE 5.17. nxplayer return error “Cannot detect any display running. Do you want NoMachine to create a new display and proceed to connect to the desktop?”

    Steps to reproduce:

    1. Install Archlinux with KDE or use a preconfigured image https://www.osboxes.org/arch-linux/ (DirectDL https://sourceforge.net/projects/osboxes/files/v/vb/4-Ar—c-x/2019.05/KDE/201905-kde-64bit.7z/download)

    2. Upgrade to recent packages (pacman -Suy) and install NXServer

    3. Try to connect to that VM

    #24078
    Avatar
    Britgirl
    Keymaster

    Please see:

    https://www.nomachine.com/TR10Q09440

    The correct workaround is:

    – edit /usr/NX/etc/node.cfg, and change the following key:

    DefaultDesktopCommand “/usr/bin/dbus-launch /usr/bin/startplasma-x11”

    #24082
    Avatar
    brugi
    Participant

    I’m having the same problem (another thread here) and, as jnko said, this doesn’t help.

    It’s because NX does not need to start Plasma, it’s already running and we are trying to connect to physical desktop. From some reason X server with KDE 5.17 is not detected by NX.

     

    #24085
    Avatar
    jnko
    Participant

    The workaround works fine for Archlinux.

     

    Thanks a lot!

    #24090
    Avatar
    jnko
    Participant

    Uups, sorry. Was too fast on my last post.

    As already stated by brugi this workaround is only a half fix.

    It will work when no session is active, e.g. with sddm login manager, but NOT when a session has alreeady been started. In this case we’ll get the error from first post.

    #24091
    Avatar
    brugi
    Participant

    OK, sorry for wrong assumption, I tried with this few days ago and it didn’t work. Now I double-checked for typos or something, but no luck. So I envy you. πŸ™

    I’m on Arch Linux too and still get “Cannot detect displays” and this:

    ~ sudo /etc/NX/nxserver –restart
    NX> 162 Disabled service: nxserver.
    NX> 162 Service: nxnode already disabled.
    NX> 162 Disabled service: nxd.
    NX> 111 New connections to NoMachine server are enabled.
    NX> 161 Enabled service: nxserver.
    NX> 162 WARNING: Cannot find X servers running on this machine.
    NX> 162 WARNING: A new virtual display will be created on demand.
    NX> 161 Enabled service: nxd.

    Service nxnode remains disabled.

    ~ sudo /etc/NX/nxserver –status
    NX> 111 New connections to NoMachine server are enabled.
    NX> 162 Enabled service: nxserver.
    NX> 162 Disabled service: nxnode.
    NX> 162 Enabled service: nxd.

    #24108
    Avatar
    og00r
    Contributor

    About that warnings:

    ‘NX> 162 WARNING: Cannot find X servers running on this machine.

    NX> 162 WARNING: A new virtual display will be created on demand.’

    It happens because NoMachine cannot find correct session with new plasma in version 5.17.
    There is Trouble Report for it (separate from TR10Q09440):

    https://www.nomachine.com/TR10Q09441

    As there is no workaround at this moment we could prepare packages with fix for you, but you should confirm what packages you are using (nxserver –version) on what architecture (x86 or x64).

    #24112
    Avatar
    brugi
    Participant

    I’m using Arch Linux, x64, NoMachine version 6.8.1.

    Thanks! Fingers crossed. πŸ™‚

     

    #24127
    Avatar
    otakuxtom
    Participant

    I also have such issue in my KDE 5.17

    I am using

    NoMachine – Version 6.8.1

    hope there will be a solution soon.

    #24164
    Avatar
    brugi
    Participant

    I can confirm that patch that you sent by email works for me. Thank you very much!

     

    #24167
    Avatar
    jnko
    Participant

    @brugi: What patch? Could you share it with us, please?

     

     

    #24170
    Avatar
    jeffm999
    Participant

    having same issue as those above :

    OS=arch, x64 ; plasma 5.17 ; NoMachine 6.8.1

    looking forward to a fix

    #24174
    Avatar
    Britgirl
    Keymaster

    All those who are on this thread should now have received an email from us. Please check your email inboxes πŸ™‚

    #24177
    Avatar
    mantoshelis
    Participant

    Can I get this patch also? I experience same problem on KDE 5.17 and Arch Linux with NoMachine version 6.8.1.

    Thanks a lot.

Viewing 15 posts - 1 through 15 (of 33 total)

You must be logged in to reply to this topic.