Nxd does not start from systemd, but does from nxserver –restart

Forums / NoMachine for Linux / Nxd does not start from systemd, but does from nxserver –restart

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #41281
    jamin.collins
    Participant

    When started from systemd, it appears that nxd is not started.

    $ sudo systemctl restart nxserver
    $ sudo /etc/NX/nxserver --status
    NX> 111 New connections to NoMachine server are enabled.
    NX> 161 Enabled service: nxserver.
    NX> 161 Enabled service: nxnode.
    NX> 162 Disabled service: nxd.
    $ sudo netstat -ntlup | grep nx
    tcp 0 0 127.0.0.1:12001 0.0.0.0:* LISTEN 29795/nxnode.bin
    tcp 0 0 127.0.0.1:22598 0.0.0.0:* LISTEN 29712/nxserver.bin
    tcp 0 0 127.0.0.1:22597 0.0.0.0:* LISTEN 29712/nxserver.bin
    tcp 0 0 127.0.0.1:7001 0.0.0.0:* LISTEN 29795/nxnode.bin
    tcp6 0 0 ::1:7001 :::* LISTEN 29795/nxnode.bin
    udp 8448 0 172.17.0.1:5353 0.0.0.0:* 29712/nxserver.bin
    udp 8448 0 192.168.10.188:5353 0.0.0.0:* 29712/nxserver.bin
    udp 0 0 0.0.0.0:5353 0.0.0.0:* 29712/nxserver.bin
    udp        0      0 0.0.0.0:5353 0.0.0.0:* 28884/nxserver.bin

    However, if I issue nxserver --restart:

    $ sudo /etc/NX/nxserver --restart
    NX> 162 Service: nxd already disabled.
    NX> 162 Disabled service: nxserver.
    NX> 162 Disabled service: nxnode.
    NX> 111 New connections to NoMachine server are enabled.
    NX> 161 Enabled service: nxserver.
    NX> 161 Enabled service: nxnode.
    NX> 161 Enabled service: nxd.
    $ sudo netstat -ntlup | grep nx
    tcp 0 0 127.0.0.1:21924 0.0.0.0:* LISTEN 29091/nxserver.bin
    tcp 0 0 127.0.0.1:21923 0.0.0.0:* LISTEN 29091/nxserver.bin
    tcp 0 0 0.0.0.0:4000 0.0.0.0:* LISTEN 29121/nxd
    tcp 0 0 127.0.0.1:12001 0.0.0.0:* LISTEN 29188/nxnode.bin
    tcp 0 0 127.0.0.1:7001 0.0.0.0:* LISTEN 29188/nxnode.bin
    tcp6 0 0 ::1:7001 :::* LISTEN 29188/nxnode.bin
    tcp6 0 0 :::4000 :::* LISTEN 29121/nxd
    udp 0 0 0.0.0.0:4000 0.0.0.0:* 29121/nxd
    udp 8448 0 172.17.0.1:5353 0.0.0.0:* 29091/nxserver.bin
    udp 8448 0 192.168.10.188:5353 0.0.0.0:* 29091/nxserver.bin
    udp 0 0 0.0.0.0:5353 0.0.0.0:* 29091/nxserver.bin
    udp6 0 0 :::4000 :::* 29121/nxd

    How can I make sure that nxd is started from the systemd service?

    #41348
    zaq
    Contributor

    Hello

    We need more info, could you prepare log package as is described in:

    https://kb.nomachine.com/DT10O00163#1.1

    Pls run this commands one after another:

    1. /etc/NX/nxserver --version

    2. sudo /etc/NX/nxserver --shutdown

    3. ps -efja | grep nx

    4. sudo systemctl start nxserver

    5. systemctl status nxserver

    6. ps -efja | grep nx

    and send output, the logs package to forum[at]nomachine[dot]com.

    Which distribution of Linux do you use?

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.