NXD service does not start at boot Ubuntu 16.04

Forums / NoMachine for Linux / NXD service does not start at boot Ubuntu 16.04

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #14671
    xsyourpal
    Participant

    My server runs in a multiuser.target mode.  (Instead of graphical.target run level).    Whenever  I start or reboot the server,  only the nxserver service is enabled and both nxnode and nxd are disabled.   Therefore I am not able to connect to the virtual display.

    However,  if I reinstall the NoMachine package then the nxd service is enabled and I am able to connect to the virtual display that is created.  Every time I restart my server the nxd is disabled and I am unable to –restart it.   I have to completely remove and re-install NoMachine and then as mentioned before nxd comes up enabled..

    If the server is run in graphical.target runlevel then there is no problem and all three services start at boot.

    Please let me know if there is some configuration that I am missing for servers that do not start in graphical.target runlevel.

     

    #14804
    Britgirl
    Keymaster

    Our developers tried to reproduce the problem in the same environment you have, but without success.

    All the NoMachine services work properly on Ubuntu 16.04 and multiuser.target as run level.

    Do you confirm that NoMachine Server is installed on Ubuntu 16.04?

    Did you have the same problem also with NoMachine server on CentOS 7.3?

    Additionally, we would like to check logs from the NoMachine server host.

    Please send us a tar.gz archive of the /usr/NX/var/log directory from such host. You can send directly to forum[at]nomachine[dot]com making sure to place the title of the topic in the subject.

Viewing 2 posts - 1 through 2 (of 2 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.