Nxhtd start problem

Forums / NoMachine Cloud Server Products / Nxhtd start problem

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #10650
    michael.henke
    Participant

    For evaluation purposes I am attempting to get the most recent Cloud Server version on CentOS 7.2 to work.

    I fail however to start the nxhtd server with the following error message

    [root@emulator bin]# ./nxserver –start nxhtd
    NX> 500 ERROR: Support for HTTP server is not permitted on this server.
    [root@emulator bin]#

    which I could not spot in the online documentation.

    Thanks for any help

    Michael

    #10676
    vnaipaul
    Participant

    Hi Michael,

    Check the ClientConnectionMethods parameter in NX/etc/server.cfg (node.cfg).  I think it should include “HTTP”.

    – Val

    #10683
    irek
    Participant

    Hello Michael,

    there are generally 3 reasons for having this error message:


    NX> 500 ERROR: Support for HTTP server is not permitted on this server.

    1. Key ‘ClientConnectionMethods’ is disabled in server.cfg.
    2. Missing ‘HTTP’ parameter in the ‘ClientConnectionMethods’ key in server.cfg.
    3. License is not Cloud Server.

    So Val is right to suggest to check ‘ClientConnectionMethods’ in server.cfg

    Please be sure that ‘ClientConnectionMethods’ key is enabled and included ‘HTTP’, for example:


    ClientConnectionMethods NX,SSH,HTTP

Viewing 3 posts - 1 through 3 (of 3 total)

This topic was marked as solved, you can't post.