NXNode not showing in Accessibility

Forums / NoMachine for Mac / NXNode not showing in Accessibility

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #42178
    Haider
    Participant

    Hello,

    I installed NoMachine Free version on 2 Macs, both running OSX 10.13.6.  After the installation was completed I went to Security & Privacy panel and allowed No Machine from the General tab.  I then went to the Privacy tab to enable NX Node under accessibility but it wasn’t there.  I removed both installations and tried again with the same results.  Any idea why this is happening and how to fix it?  I do have [removed] installed right now on both machines.  Could there be a conflict between the 2?

    Thank you

    #42353
    Haider
    Participant

    Hello,

    Does NoMachine work with OSX 10.13.6?

    Thanks,

    #42377
    Britgirl
    Participant

    Yes, NoMachine installs correctly and works out-of-the-box on macOS 10.13. Are you using the latest version? It is not necessary to have to manually enable/set permissions on earlier versions of macOS.

    If you have installed and not been able to connect or are seeing an error of some sort, please provide steps to reproduce and possibly a screenshot of what you are seeing. Thanks!

    #42380
    Haider
    Participant

    Hello Britgirl,

    Thank you for getting back to me.  I have installed v8.2.3 on 2 Macs both running OSX 10.13.6.  Both installation completed successfully.  I then clicked “ADD” in the main window and added the other computer and grabbed the nx address from the Settings – Status window.  Now when I try to connect, I get the following error: “A connection timeout has occurred while trying to connect to ‘IP ADDRESS’ on port ‘4000’. The issue could either be caused by a networking problem, by a firewall or NAT blocking incoming traffic or by a wrong server address. Please verify your configuration and try again.”

    The online documentation says something about enabling NXNode in System Preferences – Security & Privacy.  I don’t see anything under Accessibility on both Macs.

    Hope you can help.

    Regards,

    Haider

     

     

    #42384
    Britgirl
    Participant

    On versions of macOS prior to Catalina, NoMachine installs without having to manually set permissions in the Accessibility section of the OS. You can read more about this here, but it should not affect you because you are running High Sierra.

    https://kb.nomachine.com/AR11Q01061

    The fact that you can start a connection is proof that NoMachine is installed correctly on at least one of the Macs 🙂

    So, to connect, in your Add panel, you must put the IP address of the Mac (the NoMachine server) you want to reach. This is obtained by checking what NoMachine prints in the Server status panel for that machine. If the two computers are on the same network, perhaps on your home network(?), you should use the IP address that generally starts with 192.xx, like in the example in our Getting Started Guide, Fig. 2 https://www.nomachine.com/getting-started-with-nomachine.

    The error you are receiving generally appears when you are connecting over the Internet (so the two computers are not on the same LAN). If that’s the case, you need to enable UPnP to allow NoMachine to automatically configure port-mapping. It might also be necessary to enable port-forwarding on your router. Please consult this article and follow the instructions there: https://kb.nomachine.com/AR04S01122.

    #42403
    Haider
    Participant

    Hi Britgirl,

    Thank you for the information you sent me.  I think I have a problem with port forwarding on my router.  I’ll try to solve it and hopefully it will make NoMachine work for me.

    Regards,

    Haider

    #42632
    Britgirl
    Participant

    When we release NoMachine Network in the future port-forwarding won’t be necessary, and it will be possible to connect without knowing the IP address of the computer you want to connect to 🙂

    You can see more about this feature on our website here:  https://www.nomachine.com/network

    #42641
    Haider
    Participant

    Hi Britgirl,

    Thank you for the update.  Your plans for the new release is how all the other remote access applications work and it makes life easier for everyone.  When is the new release due?

    Thanks,

    Haider

    #42739
    Haider
    Participant

    Hi Britgirl,

    I am able to establish connection internally but have not been able to establish connection over the internet. Port Forwarding in the router is configured correctly. I scanned open ports and the port I selected 4001 is there. Yet, connection fails every time. I checked the log files and this is what I see:

    Info: Starting NoMachine version 8.3.1.

    Info: Loading settings from ‘/Users/xxx/.nx/config/player.cfg’.

    Info: Loaded translation files for ‘English’.

    23398 775 2023-01-28 14:50:53 984.497 Main: Creating the client session.

    23398 775 2023-01-28 14:50:53 984.633 ClientSession: Initializing session at 0x7fbb1806e200.

    23398 775 2023-01-28 14:50:55 100.099 ClientSession: Initialized session at 0x7fbb1806e200.

    23398 775 2023-01-28 14:50:55 102.895 ClientSession: Starting session at 0x7fbb1806e200.

    23398 775 2023-01-28 14:50:55 106.287 ClientSession: Going to start session ‘/Users/xxx/Documents/NoMachine/Mac Mini – External.nxs’.

    23398 775 2023-01-28 14:50:55 117.651 Connection: Initializing connection at 0x7fbb17da71d0.

    23398 775 2023-01-28 14:50:55 117.751 Connection: Initialized connection at 0x7fbb17da71d0.

    23398 775 2023-01-28 14:50:55 117.781 Connection: Starting connection at 0x7fbb17da71d0.

    23398 775 2023-01-28 14:50:55 117.795 ClientDaemonConnector: Starting a new connection to host ‘xxx.xxx.xxx.xxx’ on port ‘20312’.

    23398 775 2023-01-28 14:50:55 118.092 Connection: Started connection at 0x7fbb17da71d0.

    23398 775 2023-01-28 14:50:55 124.055 ClientSession: Started session at 0x7fbb1806e200.

    Info: Slave server running with pid 91651.

    Info: Listening to slave connections on port 60167.

    23398 775 2023-01-28 14:50:55 125.482 Main: Entering the GUI event loop.

    23398 775 2023-01-28 14:50:55 926.771 Connection: Connection at 0x7fbb17da71d0 failed.

    23398 775 2023-01-28 14:50:55 926.843 ClientSession: Runnable at 0x7fbb17da71d0 caused the session at 0x7fbb1806e200 to fail.

    23398 775 2023-01-28 14:50:55 926.868 ClientSession: Failing reason is ‘The remote host ‘xxx.xxx.xxx.xxx’ refused to establish a network connection on port ‘20312’. Please verify that NoMachine is correctly installed and listening on the port where you are trying to connect, and that incoming traffic is not being blocked by a firewall or NAT.’.

    23398 775 2023-01-28 14:50:55 935.161 ClientSession: Stopping session at 0x7fbb1806e200.

    23398 775 2023-01-28 14:50:55 947.380 ClientSession: Destroying display client.

    Info: Slave server running with pid 126215.

    Info: Listening to slave connections on port 30495.

    23398 775 2023-01-28 14:50:55 950.448 Connection: Stopping connection at 0x7fbb17da71d0.

    23398 775 2023-01-28 14:50:55 950.640 ClientDaemonConnector: Stopping the current connection.

    23398 775 2023-01-28 14:50:55 950.687 Connection: Stopped connection at 0x7fbb17da71d0.

    23398 775 2023-01-28 14:50:55 963.360 ClientSession: Stopped session at 0x7fbb1806e200.

    objc[23398]: Class FIFinderSyncExtensionHost is implemented in both /System/Library/PrivateFrameworks/FinderKit.framework/Versions/A/FinderKit (0x7fffadb58cd0) and /System/Library/PrivateFrameworks/FileProvider.framework/OverrideBundles/FinderSyncCollaborationFileProviderOverride.bundle/Contents/MacOS/FinderSyncCollaborationFileProviderOverride (0x1168b1cd8). One of the two will be used. Which one is undefined.

    Any ideas where the problem is?

    At the same time, I have run into a couple of strange problems. Connections I have deleted in the past reappear and they can’t be deleted. When I configure ports, I can’t seem to choose a different port number beside the default 20312.

    I just upgraded to the new release v8.3.1.

    Regards,

    Haider

    #42751
    Britgirl
    Participant

    Did you follow the instructions in the article I mentioned earlier (AR04S01122)? Specifically this section which explains how to enabled port-mapping:

    2.2. Enabling the NoMachine UPnP/NAT-PMP automatic Port Forwarding via UI

    By default the automatic port mapping on the router is disabled in NoMachine, also in the free version.To enable it, go on the remote computer and do the following.

    Open the NoMachine interface -> Settings -> Server -> Ports and select the nxd service, then click on Configure, tick the option ‘Use UPnP to map the port on the gateway IP’

    At the same time, I have run into a couple of strange problems. Connections I have deleted in the past reappear and they can’t be deleted. When I configure ports, I can’t seem to choose a different port number beside the default 20312.

    Are you sure these are connection files? Could they be computers being advertised on your local network? The latter is represented with a “pipe”, the former by the !M icon (https://www.nomachine.com/finding-other-nomachine-computers-on-the-same-network). Send us a screenshot of your Machines roster.

    #42762
    Haider
    Participant

    Hi ,

    Yes I followed the instructions.  Please see images below.

    Do you have logs on the server side to see what is happening with connections?

    You are right, the connections that show up are in fact advertised services. I created connections in the past with the same names.

    Regards,

    Haider

    Attachments:
Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.