Nxnode, nxservice active when stopped

Forums / NoMachine for Windows / Nxnode, nxservice active when stopped

Tagged: 

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #20552
    AvatarLloyd Andrew
    Participant

    NoMachine Network services shows the host server status as “Stopped.”  Startup is “Manual” and the host has not been started since the last Windows boot.  Yet Windows (7 Professional 64-bit) Task Manager shows nxservice is running and a couple of dozen bytes are added each second to “I/O Other Bytes” for nxnode.bin *32,  more than 1000 bytes each second for nxservice64.exe, and bytes are added occasionally for nxserver.bin *32.  CPU for those processes are negligible.  Process nxclient.bin *32 shows no activity.  What are they doing at all when NoMachine isn’t even supposed to be running?

    #20555
    Avatarkroy
    Contributor

    Is it possible you didn’t disable the automatic start-up of NoMachine at boot? To disable it:

    – Click on the Monitor (the !M icon) in the system tray to open the menu
    – Click on ‘Show the service status’
    – Choose ‘Shut down the server’
    You will be asked whether you want to restart the server or not at the next boot
    – Click on ‘No’.

    More information you can find there: https://www.nomachine.com/AR04L00800.

     

    #20561
    AvatarLloyd Andrew
    Participant

    Perhaps I need more information:  I don’t see “Show the service status” anywhere, but I see “Shut down the server” on the Server status dialog, which already says “Server not running.”  From the NoMachine Service / Server Preferences dialog, “Start automatic services at startup” and Advertise this computer on the local network” are unchecked.  “Startup” says “Manual, and “Status” says “Stopped” as I already mentioned.

    I did find under Windows services, however, an entry for “NoMachine Device Server” / nxservice which was Started with Startup type “Automatic (Delayed Start)”.  I stopped that and set the Startup type to “Manual.”  That removed all the NoMachine processes from Task Manager and they did not start again after a reboot, which explains my main question.

    But I still don’t see where this is controlled from NoMachine.  The comment under “Start automatic services at startup” (which, as I said, is unchecked) reads “Services marked as automatic will be started when the machine starts.”  Is that referring to the Windows dialog?  All of the “Forwarded devices” are checked, but the comment there reads “Select which devices can be made available when connected,” and there is no connection.

    I now remember a couple months ago trying to setup remote device access and never got it to work (I was mainly interested in a USB disk drive).  Evidently the screen, keyboard and mouse services are distinct from other devices.  Is there a tutorial somewhere for setting up access to a remote disk drive (on both ends)?  I can’t find any.  It would be helpful to clearly distinguish client and server settings in all situations, and I find some of these ambiguous.

    Thanks.

    #20572
    Avatarkroy
    Contributor

    If you have NoMachine version 6 you can use also NoMachine Monitor’s menu item “Close the NoMachine application” (https://www.nomachine.com/AR11P01005). After click it will show question: “Do you want to run the NoMachine application at the next startup?” to permit to start automatically the server at next reboot. The administrator will also have the option of not being asked that question again the next time the NoMachine application will be closed, with a “Do not ask this question anymore” box.

    Is there a tutorial somewhere for setting up access to a remote disk drive (on both ends)?

    Please refer https://www.nomachine.com/accessing-files-on-local-or-remote-disk-drives.

    #20578
    Avatarsil04
    Keymaster

    Hello Lloyd Andrew,

    the first reply to this topic seems to have misinterpreted your initial question.

    Let me clarify differences between ‘Stop the server’ and ‘Shutdown the server’ and how manual/automatic startup of services is intended to work (I will adopt naming convention used in v. 6).

    ‘Stop the server’ means that NoMachine server will not accept incoming new connections to your computer.
    If there’s already a connection, it remains active. All NoMachine services remain also running.

    ‘Shutdown the server’ means to terminate all NoMachine services. So, if you shutdown the server you should not find any active NoMachine service among your Windows services.

    When you choose to shutdown the server, you will be requested if you want to automatically start NoMachine (server and all services) at next reboot or not.

    About the NoMachine Network services panel in the GUI and your comment:

    > NoMachine Network services shows the host server status as “Stopped”

    This panel shows the status of nxd, the NoMachine network daemon (NX) in charge to accept connections to this host on default port 4000.  This service can be stopped and restarted and also configured for manual/automatic start at boot via this panel. Such settings apply only to this service, not to all NoMachine processes.

    As a further note, the previous replies point to a couple of articles which explain more in detail how to shutdown NoMachine (server and all services) and set the manual start mode at reboot. There are alternative ways to do that.

    If you use v. 6, this is the fastest way: https://www.nomachine.com/AR11P01005

    For previous versions, see https://www.nomachine.com/AR04L00800 (it applies also to v. 6).

Viewing 5 posts - 1 through 5 (of 5 total)

This topic was marked as solved, you can't post.