Nxplayer crashes upon connection with SIGABRT

Forums / NoMachine for Linux / Nxplayer crashes upon connection with SIGABRT

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #32820
    Avatarmries
    Participant

    Hi,

    I am unable to use the nxplayer, the problem occurred recently and is persistent without me being able to correlate it to what might have changed.
    Upon connection, the nxplayer just crashes with SIGABRT.

    The client I am using is the most recent Linux version of the enterprise client on an Ubuntu 20.04 LTS (up to date).

    The server is running also on a Linux machine on version 5.3.29 supplying a virtual display.

    I have tried to (with no effect)

    • update to the most recent version of the client (uninstall & install)
    • removal of local data (.nx)
    • connect to a different server

    If I connect from a windows VM running on the same client machine with the most recent version of the Windows-enterprise-client everything works.

    Any hints on what could be the issue?

    debugging info:

    /usr/NX/bin/./nxplayer server.nxs
    Aborted (core dumped)

    /usr/NX/bin/./nxplayer --version
    NXPLAYER - Version 7.4.1

    uname -a
    Linux ... 5.8.0-48-generic #54~20.04.1-Ubuntu SMP Sat Mar 20 13:40:25 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux

    prepared the terminal for debugging with:

    • NX_SYSTEM=/usr/NX
    • export NX_SYSTEM
    • LD_LIBRARY_PATH="$NX_SYSTEM/lib"
    • export LD_LIBRARY_PATH

    Attachments:
    #32836
    AvatarCarin
    Participant

    Hi mries,

    your debugging details have been removed and added as an attachment to avoid having long amounts of files content in the thread 😉

     

    #32843
    Avatarmries
    Participant

    Did some further debugging…

    The issue only occurs with the default windowmanager gdm3.

    When using “Ubuntu on Wayland” or “xfce” everything works as usual, i.e. no error occurs.

     

     

    Attachments:
    #32874
    AvatarCarin
    Participant

    Hi mries,

    It looks like the problem is something that happens between iHD_drv_video.so and libigdgmm.so.
    To avoid the problem and be able to use gdm3, please try to disable hardware decoding in nxplayer. You can disable it completely in the player.cfg. Please edit the file$HOME/.nx/config/player.cfg and set the configuration key “Enable hardware accelerated decoding” to “disabled”.

     

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.