Nxserver restarts after “Reached maximum NXD restart counter” warning

Forums / NoMachine Terminal Server Products / Nxserver restarts after “Reached maximum NXD restart counter” warning

Tagged: 

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #37439
    ivan3000
    Participant

    New install of NoMachine Terminal ServerĀ  7.8.2 on RHEL 7.6

    The nxd service crashes and is restarted until it reaches the maximum restart counter, as seen in log:

    NXSERVER WARNING! Reached maximum NXD restart counter.

    Debug logs sent to forum@nomachine.com

    Any idea what is wrong with the installation?

    SSH works, but would like to use NX protocol since its probably better performance.

    # /etc/NX/nxserver --restart
    
    NX> 162 Disabled service: nxserver.
    
    NX> 162 Service: nxnode already disabled.
    
    NX> 162 Service: nxd already disabled.
    
    NX> 162 Disabled service: nxhtd.
    
    NX> 111 New connections to NoMachine server are enabled.
    
    NX> 161 Enabled service: nxserver.
    
    NX> 162 WARNING: Cannot find X servers running on this machine.
    
    NX> 162 WARNING: Only connections to virtual displays are possible.
    
    NX> 161 Enabled service: nxd.
    
    NX> 161 Enabled service: nxhtd.
    
    /etc/NX/nxserver --status
    
    NX> 111 New connections to NoMachine server are enabled.
    
    NX> 161 Enabled service: nxserver.
    
    NX> 162 Disabled service: nxnode.
    
    NX> 162 Disabled service: nxd.
    
    NX> 161 Enabled service: nxhtd.
    #37509
    Britgirl
    Keymaster

    It could be that port 4000 is already taken. The Network Server (nxd) listens by default on port 4000. If you have another application using port 4000, you can change it for NoMachine in server.cfg.

    More about default ports that NoMachine uses is here:
    https://knowledgebase.nomachine.com/AR01L00770

    How to solve port conflicts with other applications
    https://knowledgebase.nomachine.com/AR11L00823

Viewing 2 posts - 1 through 2 (of 2 total)

This topic was marked as solved, you can't post.