NX Server settings

Forums / NoMachine for Linux / NX Server settings

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #2227
    S.Herrmann
    Participant

    Hello,

    I am installed the new version “nomachine_4.0.370_1_x86_64.rpm” .

    With the older version “3.5” I could settle commands in the console, which warn always very helpful to me. #nxserver –list –message, start, stop…

    In the new version I only see that the service is running nothing more.

    How can I now see the currently running sessions in the Linux console? I myself do not have a Windows computer at my workplace, it should go only via the nx-client.

    Thanks

    #2249
    Britgirl
    Keymaster

    Hi, it’s not clear what the problem is. In version 4, the commands are exactly the same nxserver –list and so on. Are you getting errors? If so, can you tell us what they are?

    #2264
    titan
    Participant

    Britgirl,

    I think S.Herrmann refers to the fact the nxserver command is not put in the PATH environment, so that the user has to specify the full path on the command line. This was a design choice at the beginning of the 4 development to avoid making any change to the host environment that may interfere with the system (even if version 4 is a completely self-contained environment and there is little or no overlap with libraries and programs that may be installed on the host). I think we should re-evaluate this choice. While it makes NoMachine easier to manage and more secure for the advanced user that may set the path on a per-user basis, it also makes life for the average user harder.

    In any case these are the paths on different operating systems:

    Linux:

    /usr/NX/bin/nxserver

    Windows:

    C:\\Program\ Files\\NoMachine\\bin\\nxserver

    Mac:

    /Applications/NoMachine.app/Contents/Frameworks/bin/nxserver

     

    #2265
    S.Herrmann
    Participant

    Hello Titan,

    thanks for the answer.

    The problem is resolved. it was the environment variable that the commands nxserver were not found. Now I have a question. Do I have the right version installed? Acquired we have licenses for the installation of “nxnode, nxclient and nxserver”

    Date: Tue Jun 25 09:49:27 CEST 2013
    Product: NX Enterprise Server Subscription
    Customer: xxxxxxxxxxxxxxxxxxxxxxxx
    E-mail: xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
    Product Id: LESS
    ….
    ….
    Currently I have installed no machine-terminal-server-evaluation_4.0.370_2_x86_64.rpm

    Is that the correct version of our licenses? Sorry, but in the many new releases I look no more by what is ultimately responsible for what?

    Thanks again for the support.
    S.Herrmann
    #2263
    S.Herrmann
    Participant
    Hi, thanks for the answer.
    When I am logged in as “root” and give a command “nxserver –list” then I get the message..
    bash: nxserver: command not found
    The nxserver Service is running and the NX connection from the windows client to the server goes.
    Thanks
    #2280
    Britgirl
    Keymaster

    NoMachine Terminal Server v.4  = NX Enterprise Server 3.5.0. See this article here which explains what you need to use in version 4 based on what you were using in 3.x. https://www.nomachine.com/AR09K00689

    #2283
    S.Herrmann
    Participant

    Hello, thanks for the hint.

    #2293
    S.Herrmann
    Participant

    So, now everything runs fine. Thanks again for the help. Now I only have the problem that the new installation does not recognize our existing license. This should be compatible yet. Must the licence.lic” and the “node.lic are copied to a different place than in version 3.5? Or I have to let our existing license upgrade with them?

    The error message is:
    NX> 611 No subscription information found. Please visit the
    NX> 611 NoMachine web site at http://www.nomachine.com/
    NX> 611 to acquire a valid subscription.
    NX> 611 The NX server can’t perform the requested operation.
    NX> 999 Bye.

    Our license:
    Product: NX Enterprise Server Node
    Expiry: Thu Jun 12 09:49:27 CEST 2014
    I installed:
    nomachine-terminal-server-evaluation_4.1.28_3_x86_64.rpm
     

    That’s right. In your description, is that of NX Enterprise Server 3.5 is —> NoMachine Terminal Server 4.

    Thank you

    #2320
    Britgirl
    Keymaster

    The correct command to update RPM packages is:

    rpm -U <package_name>

    and in the case of DEB
    dpkg -i <package_name>

    So using this command when upgrading to Terminal Server from NX Enterprise Server 3. Did you use either of these? We’ve checked to make sure, and if everything is working ok. If you did, we appreciate seeing the installation logs so we can see what happened and fix it. Just zip up the VAR logs and send them to us http://https//www.nomachine.com/AR07K00677

    To fix the problem, you should copy the lic files to /usr/NX/etc/. If that doesn’t help, do a reinstall.

     

     

Viewing 9 posts - 1 through 9 (of 9 total)

This topic was marked as solved, you can't post.