On Debian 10 there is no way to install a shared desktop

Forums / NoMachine for Linux / On Debian 10 there is no way to install a shared desktop

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #37397
    vetrov
    Participant

    Debian 10 there is no way to install a shared desktop

    Debian 9 then everything is ok and in stock

    #37472
    Britgirl
    Keymaster

    We need logs from the server side to understand why the server is not running and therefore why you cannot enable ‘Desktop shared’. Please see here for instructions on how to extract them. https://knowledgebase.nomachine.com/AR10K00697

    Send them directly to forum[at]nomachine[dot]com making sure you put the title of this topic as the subject of your email.

    Also a screenshot of the Server Status. Open NoMachine, go to Settings, select Server, then Status. Thanks.

    #37483
    vetrov
    Participant

    First cleaning, then collecting the log

    #37488
    vetrov
    Participant

    vetrov@astra210:~$ echo $XDG_SESSION_TYPE
    x11

    echo $XDG_SESSION_TYPE

    Attachments:
    #37528
    Britgirl
    Keymaster

    It could be a permissions problem because logs show NoMachine doesn’t have access. What’s the output of ls -l /proc/net/unix? Are you connecting to a physical Linux machine or is it a virtualized machine of some kind?

    #37531
    vetrov
    Participant

    physical machine

    after starting the remote connection

    on a remote physical machine does not work application PulseAudio

    before remote connection to a physical machine

    the poster comes out

    I can’t find the monitor

    creating my own and connects by creating a separate session

    connections not what you need

    flattening the virtual but in properties like physical

     

    #37540
    Britgirl
    Keymaster

    We noticed that the permissions of /proc/net/unix are set to 400. Default on Debian 10 is 444 – did you change this by yourself or can you determine if it has been changed by some application which you are using?

    Setting again permissions to 444 should fix the problem.

    #37553
    vetrov
    Participant

    It helped

    Setting again permissions to 444 should fix the problem

    thank you very much

    The theme is completed

    #37554
    digitroller
    Participant

    Hi! Logged to confirm solution.

    Distro called Astra Linux, based on Debian 10. Setting permissions /proc/net/unix to 444 worked. Thanks!

Viewing 9 posts - 1 through 9 (of 9 total)

This topic was marked as solved, you can't post.