One minute delay before connection established

Forums / NoMachine for Windows / One minute delay before connection established

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #8878
    cacophony555
    Participant

    Since upgrading my client to the new version a few weeks ago (from a very old version 3.something) I’ve noticed that it now takes exactly 1 minute for the connection to my remote server to be established:

    * I’ll double click NoMachine on my client, select the server and enter the password

    * Then there will be a white screen for exactly 1 minute

    * And finally it the remote machine display will appear and I can log in

    This has happened 100% of the time and only started occurring after I upgraded my client software. Currently I’m running latest NoMachine on both my client and server.

    #8883
    Britgirl
    Keymaster

    The following information would be useful:

    – NoMachine product on local and remote machine (free version, Workstation, etc).
    – Whether the problem arises connecting to a physical or a virtual display.
    – Remote and local Windows/Mac/Linux version (Windows XP/7/8, OS X 10.x, Ubuntu xyz, Mint x.y, etc.).
    – If on Linux, desktop version (GNOME. KDE, whatever) on client and on server.

    #8885
    fra81
    Moderator

    Can you also tell us if you are using the SSH or the NX protocol? If you are connecting with SSH, one possible reason is a timeout in the DNS reverse lookup. In that case a solution is adding the following in the ‘sshd_config’ file on the server:

    UseDNS no

    #8937
    cacophony555
    Participant

    To answer the questions:

    – Free version for both local and remote

    – Physical displays (dual monitors connected to remote machine)

    – Remote is running Ubuntu 12.04 with Gnome, local is running Windows 7 Ultimate

    – Using the NX protocol to connect

    #8956
    fra81
    Moderator

    In the past a delay was observed due to the initialization of the hardware decoder with specific graphics cards on windows. So one thing to try is disabling the hardware decoding by changing the following key to ‘false’:

    <option key=”Enable hardware accelerated decoding” value=”true” />

    The configuration key is in the ‘C:/Users/<username>/.nx/player.cfg’ file. If you are using NoMachine 5, the same setting can be changed via the ‘Disable client side hardware decoding’ checkbox in the Display settings GUI.

     

    Should the problem persist, we would need your logs for further investigations. You can gather them as explained in https://www.nomachine.com/DT07M00098 and send them to forum[at]nomachine[dot]com.

    #8957
    cacophony555
    Participant

    Changing this value to false didn’t seem to help:

    <option key=”Enable hardware accelerated decoding” value=”true” />

    I sent logs already from my other thread, and this delay occurred for all those instances as well.

    #9578
    Britgirl
    Keymaster

    Can you tell us if you are experiencing the same problem with version 5? If so, please follow the instructions here https://www.nomachine.com/DT04M00076 and send them to us as you did before.

Viewing 7 posts - 1 through 7 (of 7 total)

This topic was marked as solved, you can't post.