One-shot only windows

Forums / NoMachine for Mac / One-shot only windows

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #11995
    AvatarMickM
    Participant

    I use nx on my MacBook Pro to connect to my Linux box to run IC design/layout software (Cadence) and display all the windows back onto my Mac (using XQuartz). I used to do this via SSH and it worked just fine, but the problem I had with that method was that if I disconnected my MacBook Pro from the network (e.g. to take it to a conference room) then all the software I was running on the linux box immediately blew up. I just love using nx because I can disconnect/reconnect the network and have all the originally displayed windows stay alive and show up again so I can keep on working :-). This is fantastic!

    I’ve confirmed the following bug only happens when I’m using the CAD tools via nx. While using the CAD tools, I can select an object and then press “q” on the keyboard to bring up a query window. If I dismiss the window I can *never* bring it up again by pressing “q” again. I have forever lost that functionality :-(. This does not happen when I connect manually via SSH and display all the windows that way.

    Just now I tried out the newly released 5.1.44 but the problem persists. I don’t think this is an XQuartz problem because the CAD tools work flawlessly when I’m connected via SSH. All that being said, I’m mostly a CAD tools user and not a linux/nx guru so my ability to debug this is constrained. However, I’m happy to provide any log files or run any experiments to debug this…

    #12021
    Avatarfra81
    Moderator

    It seems the same problem described in the following Trouble Report:

    https://www.nomachine.com/TR11M06216

    We’re going to add a reference to the Cadence application. You can check the box to be notified when it will be closed.

    #12024
    AvatarMickM
    Participant

    Many thanks for your reply – I agree that it looks like exactly that bug. Unfortunately, I work in Cadence all the time and have to go back to SSH until this is fixed. It is a little disconcerting (for me) that this was logged as a bug in November of last year and is marked with a minor priority – it completely undermines my ability to use NX until it’s fixed! I do, however, appreciate that it may not be so important to other people though…

Viewing 3 posts - 1 through 3 (of 3 total)

This topic was marked as solved, you can't post.