Ooops! error on Ubuntu Server 16.04 LTS while connecting

Forums / NoMachine for Linux / Ooops! error on Ubuntu Server 16.04 LTS while connecting

Tagged: 

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #11916
    Hypercube
    Participant

    I’m using the free version of NoMachine 5.1.40_1_amd64.deb on Ubuntu Server 16.04 LTS without X as server. On the client i’m using Linux Mint 18 and Windows 7 SP1.

    When i try to connect, i get the error “Ooops!”, please take a look at the attached screencast.

    What am i doing wrong?

    Attachments:
    #11924
    graywolf
    Moderator

    Hello, I think you need to install a desktop environment. Package dependencies will force you to install X along with the desktop environment, by the way you can run systemctl to set up the system to boot in console text mode.

    #11925
    Hypercube
    Participant

    Hi graywolf,

    i don’t think so.

    NoMachine v. 5 no longer requires to manually install a display server like Xvfb: when the local X server cannot be found, NoMachine will use its own display service (that is an embedded X server) to let users connect seamlessly a physical desktop running in background on the remote machine.

    https://www.nomachine.com/AR10K00710

    Maybe i’m missing some packages? I have a fresh installation of Ubuntu Server, just installed SSH server.

    #11931
    graywolf
    Moderator

    Yes, you won’t need to run Xvfb, NoMachine creates a display server if you keep X turned off.

    But you need a desktop anyway. What I meant is that you should install gnome:

    sudo-apt-get install ubuntu-gnome-desktop

    that will install and setup X automatically.

    So you’ll want to turn off X, specially if you have no monitor attached:

    sudo systemctl enable multi-user.target

    sudo systemctl set-default multi-user.target

    Then reboot. System will start without X and NoMachine will work as you requested.

     

Viewing 4 posts - 1 through 4 (of 4 total)

This topic was marked as solved, you can't post.