Ooops! The connection with the server was shut down via webplayer

Forums / NoMachine Terminal Server Products / Ooops! The connection with the server was shut down via webplayer

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #36474
    ddrucker
    Participant

    I’ve installed on RHEL 7 using ‘nomachine-terminal-server_7.7.4_1_x86_64.rpm’.

    On this machine, rpc.statd is using port 4000, so I set NXPort 4400 in server.cfg. This works as far as the desktop client is concerned – I can connect and get a virtual desktop.

    However, when I connect to the web version on 4443, I get “Ooops! The connection with the server was shut down.”  I tried setting “Port 4400” in ’Section “Server”’ of server.cfg, but that didn’t help.

    #36508
    irek
    Participant

    Hello ddrucker,

    if the NoMachine network daemon (nxd) is configured on the server to listen on a different port, it’s necessary to modify the web connection settings as you probably already did.

    But also it’s necessary to modify client.crt file.

    Assuming hots wasnt changed, and in Server Section is used localhost or 127.0.0.1,
    but NXD port changed to 4400

    Update the client.crt file, on Linux /var/NX/nxhtd/.nx/config/client.crt, to have:

    Host:localhost 4400
    -----BEGIN CERTIFICATE-----
    (...)
    -----END CERTIFICATE-----
    Host:127.0.0.1 4400
    -----BEGIN CERTIFICATE-----
    (...)
    -----END CERTIFICATE-----

    Please check article bellow for more details,

    https://knowledgebase.nomachine.com/AR06N00888

    #36509
    ddrucker
    Participant

    That did the trick, thanks!

Viewing 3 posts - 1 through 3 (of 3 total)

This topic was marked as solved, you can't post.