OpenSuse Leap unable to authenticate for software update

Forums / NoMachine for Linux / OpenSuse Leap unable to authenticate for software update

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #12160
    AvatarDosenfleisch
    Participant

    I tried out NoMachine free version on one tablet and two desktop computers.  It worked well enough, but I removed the installations.

    I am running two desktop machines with a fully updated version of OpenSUSE Leap 42.1. KDE client  Every time I boot, and anytime I go into the desktop software update  app,  I get a pop-up and a loud CLANG , “Authorization Failed.  You have failed to provide correct authentication.  Please check any passwords or account settings.”  So my assumption is that because I have this problem on two machines at the same time, that installation and de-installation of NoMachine has somehow caused this error.

    I’ve followed up every lead regarding Polkit including reverting to a previous version, de-installation, re-installation and the error popup is still there in the end.

    Has anyone seen this?  What did you do?  Thanks.

    #12180
    AvatarBritgirl
    Keymaster

    We’ve reproduced it and open a Trouble Report. You can check the ‘notify me’ box to receive notification of when a fix has been released.

    https://www.nomachine.com/TR08N07155

    Thanks!

    #12181
    Avatarkroy
    Contributor

    As a temporary workaround you can download correctly org.freedesktop.packagekit.policy (newest is PackageKit-1.1.3) and replace with it your currently file. You can do it using following commands.

    wget https://www.freedesktop.org/software/PackageKit/releases/PackageKit-1.1.3.tar.xz
    tar xf PackageKit-1.1.3.tar.xz
    sudo cp PackageKit-1.1.3/policy/org.freedesktop.packagekit.policy /usr/share/polkit-1/actions/

    After that please logout and login to the desktop

    #12195
    AvatarDosenfleisch
    Participant

    Wow, a confirmation that I’m not crazy and a temporary solution. I’m impressed! Thank you folks, I’ll give this a bash and let you know how I make out.

    #12223
    AvatarDosenfleisch
    Participant

    Without going into a lot of details, once everything was equal, the solution when implemented as far as I’m concerned restores the OS to its prior state.  Thanks for your help.  An interesting and quite impressive bit of software this NoMachine.  I look forward to seeing it in an OpenSUSE repository.

Viewing 5 posts - 1 through 5 (of 5 total)

This topic was marked as solved, you can't post.