OpenVZ + CentOS 6: installation problem

Forums / NoMachine for Linux / OpenVZ + CentOS 6: installation problem

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #8226
    unlim
    Participant

    I have box with CentOS6 under the OpenVZ.

    I install NoMachine as usual and get:

    ***************************************

    #/usr/NX/bin/nxserver –status
    NX> 161 Enabled service: nxserver.
    NX> 162 WARNING: Cannot find X servers running on this machine.
    NX> 162 WARNING: Connections to the physical display are not possible.
    NX> 161 Enabled service: nxd.

    ***************************************

    I tried to connect via NoMachine and get “No available sessions on this server”.

    I read the https://www.nomachine.com/AR10K00710 and perform those steps.
    Now I can connect via NoMachine but as result I see black screen.
    No server desktop – just black screen always.

    What to do ??

    #8242
    kroy
    Contributor

    Could you run debug mode and send logs from the server to forum[at]nomachine[dot]com? Instructions how to collect logs: https://www.nomachine.com/DT04M00076#1.

    #8263
    unlim
    Participant

    Seems I sorted it out.

    1. X install should be run as following:

    yum -y groupinstall “Desktop” “Desktop Platform” “X Window System”
    yum -y install xorg-x11-server-Xvfb

    2. All steps from https://www.nomachine.com/AR10K00710 should be run as USER. Except the nxserver restart.

    I create user’s script that contain all of those instructions and run it each time after server reboot.

    After that I can use NX with my VDS as needed.

Viewing 3 posts - 1 through 3 (of 3 total)

This topic was marked as solved, you can't post.