OSX keeps asking “nxd” to accept incoming connections

Forums / NoMachine for Mac / OSX keeps asking “nxd” to accept incoming connections

Tagged: , ,

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #10359
    Avatarluvis
    Participant

    The dialogue “Do you want the application “nxd” to accept incoming network connections?” Shows up every time I start my computer and never seems to get saved no matter how many times I accept. It’s not a life threatening issue but it’s annoying because I’m not the only one using the computer and others don’t know what it is so they just ignore it or kill the window etc..

    I have tried the following things but I’m now at a loss. Any help is appreciated.

    1. Complete uninstall of NoMachine and removing the settings in my firewall.

    2. Manually adding nxd as “Allow incoming connections” in my firewall. (It’s already saved in my firewall, I just removed it and tried adding it manually).

    3. Removing the ~/Library/Preferences/com.nomachine.nxdock.plist and re confirming firewall setting.

    4. In terminal force the nxd to act as “signed software”

    sudo codesign –force –sign /Applications/NoMachine.app/Contents/Frameworks/bin/nxd

    But received the following error

    /Applications/NoMachine.app/Contents/Frameworks/bin/nxd: no identity found

    So I’m at a loss. Please help.

    #10394
    AvatarBritgirl
    Keymaster

    Hi, this is a bug which has just been fixed in today’s release https://www.nomachine.com/SU07N00100

    The TR is https://www.nomachine.com/TR03N06563.

     

Viewing 2 posts - 1 through 2 (of 2 total)

This topic was marked as solved, you can't post.