Pacmd (and others) fails on Pi 4 Buster and NoMachine

Forums / NoMachine for Raspberry Pi / Pacmd (and others) fails on Pi 4 Buster and NoMachine

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #30913
    Avatarsnacey
    Participant

    Hi all, I’m new to NoMachine with Pi.

    I am running in to a problem running pacmd when logged in remotely with NoMachine using a Pi 4 Buster.  When I login via a connected console, there is no issue running pacmd.

    To get the standard LXDE-PI desktop to come up when logging in via NoMachine I had to add the line:

    DefaultDesktopCommand “/usr/bin/startlxde-pi”

    To /usr/NX/etc/node.cfg or else I got a generic LXDE desktop.   When I do this and login with NoMachine, all seems ok until I try to use any of the PulseAudio cli commands.   They all fail as follows:

    pi@PI-002:~ $ pacmd list-sinks
    No PulseAudio daemon running, or not running as session daemon.

    From reading online, this seems to be a problem with how X11 has been initialized when NoMachine logged in – but noone seems to offer any ideas on how to solve this issue.   I suspect this is simple but I can’t seem to “get” it.

    I am running the following hardware/software versions:

    Pi 4, 4GB (server), MacOS BigSur 11.1 (client)
    NoMachine:   Version 7.0.211 (arm7) — Server, Version 7.0.211 (OSX) — Client
    Raspian:  Buster (latest updates)

    Thanks for any help!

    #30950
    Avatartsotne
    Participant

    Hello,
    does it give some error when try to manually start PA daemon.

    please try and give output or error message if it gives any:
    pulseaudio -D

Viewing 2 posts - 1 through 2 (of 2 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.