Paste from clipboard trailing with NUL character

Forums / NoMachine for Windows / Paste from clipboard trailing with NUL character

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #31091
    Avatarzhenyus
    Participant

    Hi,

    Recently I upgraded my Windows NoMachine to the latest version 7.0.211_4. I found when I worked on the remote machine, pasting texts copied from the client resulting in a NUL character trailing. This is pretty annoying because not every time the NUL character is visually shown. And this character can cause various problems. I attached a screenshot showing this problem. It is when using PyCharm.

    I also tested using a Mac as a client, and there is no such bug. And after I downgraded my Windows client to version 6.6.8, this problem disappeared.

    – NoMachine product and version on local and remote machine (free version, Workstation, etc).

    Local: 7.0.211_4
    Remote: 7.0.211_4
    Both are free versions

    – Whether the problem arises connecting to a physical or a virtual display.

    Virtual display

    – Remote and local Windows/Mac/Linux version (Windows XP/7/8, OS X 10.x, Ubuntu xyz, Mint x.y, etc.).

    Local: Windows 10
    Remote: Ubuntu 18.04

    – If on Linux, desktop version (GNOME. KDE, whatever) on client and on server.

    Remote desktop: GNOME

    #31259
    AvatarBritgirl
    Keymaster

    We’ve reproduced the problem and opened a Trouble Report which you can track using the following link:

    https://www.nomachine.com/TR01S10008

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.