Performance slow between Mint 19.3/Win10

Forums / NoMachine for Linux / Performance slow between Mint 19.3/Win10

Tagged: , ,

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #27424
    Avatar10DotMe
    Participant

    My apologies, I am new to both Linux and !M.

    I have an old Dell Optiplex Desktop on which I installed Linux Mint 19.3 Cinnamon/Tricia. I then copied all my music files to it.

    I have it wired into my ethernet on my home network.

    I am remoting into it with !M.

    But all of the actions in the !M window are running in slo-mo.

    e.g. type a password, it displays a few seconds later.

    And all of the audio is struggling to play/choppy.

    Any way to increase performance?

    #27482
    Avatarfra81
    Moderator

    Hi,

    is the server a headless machine? What is the desktop environment in use?

    Logs might be useful (see https://www.nomachine.com/AR10K00697).

    #27535
    Avatar10DotMe
    Participant

    Yes. Linux Mint Tricia 19.3 Cinnamon Desktop.

    #27784
    Avatarfra81
    Moderator

    Since the machine is headless, probably it can’t use the GPU. Can you try to “turn off” the local X server on the server machine (i.e. stop the graphical session), so NoMachine will use its own embedded virtual frame buffer? You can find a couple of ways how to do it at points 1) and 2) in https://www.nomachine.com/AR03P00973.

    #27811
    Avatar10DotMe
    Participant

    Wow. First thing did it. Thanks fra81!. I haven’t tried Audio yet but my !M session is running super smooth. Its not slow or sketchy as it had been before. I do get an alert that the Graphics acceleration is off on reboot, but I can ignore that.

    OK here goes testing audio!

    Drat, I got in about a minute and it started skipping. Bummer.It definitely runs better. I’ll keep trying.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.