Permission to connect not working

Forums / General Discussions / Permission to connect not working

Tagged: 

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #23690
    Avatardadinck
    Participant

    Today I updated to NoMachine 6.8.1 (free) on both Linux (Fedora 29 xfce) and Windows 10. I have the “Require permission to let remote users connect” checked. Before the update a popup box would appear on the target machine to allow or deny a connection. After the update, both systems can connect to each other without the permissions pop-up box.

    #23696
    AvatarBritgirl
    Keymaster

    The default behaviour is that if the connecting user is the same account as the user already logged-in to the desktop, then no authorization is required. What account are you trying to connect with?

    #23701
    Avatarfisherman
    Moderator

    I could not reproduce reported problem, update does not change any settings.

    Please can you provide following information:

    1. Is it possible that you added the user as trusted or administrator on the server?
    2. Is it possible that your server was displaying login window?
    3. Is it possible that windows user accessing desktop is administrator?
    4. What was the version number you were updating from?

    As well please can you provide result from the command:

    grep PhysicalDesktopAuthorization /usr/NX/etc/server.cfg

    #23702
    Avatardadinck
    Participant

    The version I had originally was 6.7.6 (6.7.6_7?) on Windows 10 and 6.7.6_11 on Fedora 29. I thought it was a nice feature that the server will ask the user “in attendance” anyway. I wonder if this is because of persistent sessions?

    So, in looking through the /usr/NX/etc/server.cfg, I noticed in the comments that PhysicalDesktopAuthorization actually has 3 values, 0, 1, and 2. A check box can only set 0 and 1.

    A value of 2 means even the administrator needs to be approved by the desktop owner.

    The output of grep PhysicalDesktopAuthorization /usr/NX/etc/server.cfg gives

    PhysicalDesktopAuthorization 1

    So, I will have to go with the current behavior which is that the same user does not need permission. It would be nice to have the option so that NoMachine will always ask. (attended remote desktop) I would feel safer that way.

    I was connecting with the same account as the user that was logged in. In fact when I used a different account I did get the permission to connect popup window. But, on v 6.7.6, I was also given the permission popup window for the same user.

    1. Did not add any user as trusted afaik. Only approved the connection.

    2. Server was not on the login window.

    3. Windows user and linux user both have admin privileges.

     

     

    #23718
    Avatarfisherman
    Moderator

    We can confirm that the behaviour has not changed between releases.

    If that was the case, it would mean that the owner of the desktop would have to physically get up, go to the remote computer and click accept for his own connection request.

    Maybe you are confusing the authorization dialog (when it’s a different user connecting) with the notification pop-up telling you that “user xxxx connected” ?

Viewing 5 posts - 1 through 5 (of 5 total)

This topic was marked as closed, you can't post.