Physical session unavailable in NoMachine unless I physically login

Forums / NoMachine for Linux / Physical session unavailable in NoMachine unless I physically login

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #28916
    zaggynl
    Participant

    As per title, if I don’t physically login to my desktop running NoMachine server I always get a virtual session in NoMachine client.
    This session has very slow performance on login screen and is missing window management.

    If I disable my display-manager:

    sudo systemctl stop display-manager

    sudo /etc/NX/nxserver --restart

    then I get the following message from NoMachine client:

    ‘The server was unable to make the local display available or access to the local display is enabled’

     

    client free version (Windows 10) : 6.11.2

    server free version (OpenSuse Tumbleweed KDE): 6.11.2

     

    #28986
    Britgirl
    Keymaster

    We checked on the fly if there were issues with Tumbleweed and weren’t able to reproduce your issue.

    Are you clicking ‘yes’ or ‘no’ when being prompted to create a new display? Did you change anything in the server.cfg?

    Take a look at the tips here: https://forums.nomachine.com/topic/unable-to-make-the-local-display-available-or-access-to-the-local-display-is-disabled.

    #28987
    zaggynl
    Participant

    Thanks for the reply, I tried connecting later on and was able to connect to a virtual session that was much faster.

    I  received no yes/no prompt at the time.

    #29046
    Britgirl
    Keymaster

    The yes/no prompt is issued when the local X server cannot be found. NoMachine is then able to use its own display service (which is an embedded X server).

    Are you the administrator of the remote host you are connecting to? Was something changed?

    So have I understood correctly that it’s working now? If it happens again let us know.

Viewing 4 posts - 1 through 4 (of 4 total)

This topic was marked as solved, you can't post.