Pipewire support

Forums / NoMachine for Linux / Pipewire support

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #41796
    citRa
    Participant

    I’m having an issue with no sound on a headless Arch server w/ pipewire (0.3.60). Running the latest NoMachine (8.2.3). I’m not seeing any audio devices being created by NoMachine on my host.

    Any tips to get this working? I know it’s in active development. If it’s not ready to use yet, is there a way I can force NoMachine to use pipewire-pulse?

     

    #41843
    Britgirl
    Participant

    Same thread as: https://forums.nomachine.com/topic/no-sound-with-pipewire-and-el9

    The only workaround until we add support for Pipewire in virtual display sessions is to install PulseAudio and use that.

    #41888
    citRa
    Participant

    I’ve tried switching back and NoMachine isn’t creating audio devices on my Linux host. I’m using a Windows 10 client to connect.

    I’ve disabled the pipewire systemd service & confirmed that pulseaudio is running and pipewire isn’t:
    citra 4620 0.0 0.0 867076 14120 ? Sl Dec07 1:01 /usr/bin/pulseaudio --start --log-target=syslog
    citra 550912 0.0 0.1 1551956 30396 ? S<l 08:45 0:00 /usr/bin/pulseaudio --start --log-target=syslog

    #42264
    Britgirl
    Participant
    #42286
    citRa
    Participant

    I’ve confirmed that pulseaudio was already set there and have rebooted the machine to no avail. One thing I did notice when toggling audio in the client was this error in the journal:

    Jan 03 12:43:38 noobtube pulseaudio[4688]: [alsa-sink-ALC1220 Digital] alsa-sink.c: Error opening PCM device iec958:2: Device or resource busy

    #42349
    citRa
    Participant

    Ok, I was able to get output audio working by disabling autospawn in my local pulseaudio.conf and enabling the userspace systemd service. I’m unable to get a microphone to work however. NoMachine doesn’t seem to be creating an input audio device. Any thing I should look for specifically to diagnose that?

    #42375
    Britgirl
    Participant

    get output audio working by disabling autospawn in my local pulseaudio.conf

    Good. Sorry for not mentioning that last time. This is what we also suggested in other topics, for example in

    Message “Cannot find the default environment. Please contact your system administrator” on latest Slackware

    With regards to the microphone, by default microphone is always disabled, so users connected to the desktop can forward their own microphone to the session by activating it from the NoMachine menu panel inside the session. Click on the right upper corner of the session window or press Ctrl+Alt+0 to open the menu.

    Choose ‘Mic in’ icon button and click ‘Enable mic’. Sections 6.1 and 7 (Fig 18 and 19) in the following guide:

    https://kb.nomachine.com/DT09T00266#7

    Now users are able to use default microphone from the client machine in the session. To swap input device just click on ‘Change settings’ and choose other device in the ‘Microphone input’ section.

    To use input device from server machine in the session – users need only to play sound from microphone by using some application like system voice recorder.

    Does this help?

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.