Pixel-perfect fonts in 4.1

Forums / NoMachine for Windows / Pixel-perfect fonts in 4.1

Tagged: 

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #2301
    mebbe
    Participant

    There was a discussion a while ago on pixel-perfect fonts in NX 4.

    I have just installed the latest NX 4.1.28-release, and there seem to be some improvements in this area, even though they are somewhat small for my usecase.

    Whenever I move any windows or type somewhere, my terminal-windows shows blurry fonts for all fonts except where there is black-on-white text. If I stop working on the desktop, there seem to be a slow moving linear update (from top to bottom) where the fonts are ‘sharpened’ to pixel-perfectness (takes about 20 seconds to complete). Whenever I move or type in a terminal, the colored fonts are again blurry. The attached pictures shows three screenshots from this 20-second sequence.

    I am connection to a Fedora virtual desktop from windows x64, with maximum quality and have disabled all post-processing.

    Is the above behavior expected? And will this pixel-perfectness be further improved more going forward?

    #2313
    titan
    Participant

    This is an area where we need to work further. People want to be able to watch a movie and play games on NX and at the same time work in a terminal and display sharp fonts, that are two different needs difficult to reconcile, especially if you are not talking about blitting glyphs over a PCI bus but there is the network involved. To respond to your question, yes, pixel-perfectness will be much improved going forward.

    #2335
    mebbe
    Participant

    Thanks for the information! I will for sure look forward to coming improvements. It would be great if any advancements in this area are explicitly mentioned in the release notes.

    #2359
    titan
    Participant

    Did you try to play with the display settings?

    While the session is running, open the menu panel and go in Display settings. There are two check-boxes: “Disable network-adaptive” and the “Disable multi-pass”. Be sure both boxes are checked. This will maintain the quality constant and will disable the progressive refinement. You can also play with the display quality. Moving the slider to the right will improve the quality to practically lossless.

    The improvements I’m talking about are twofold: first we need to give better quality to text since the first encoding pass. We know what’s text, but video codecs are quite rigid in the way they allow the application to modify the behavior of the encoder. Enabling a feature of the codec often means disabling some other, so to get the best results we should modify the codec, but in this way we would lose the ability to link at run time and use whatever codec is available on the machine or use the HW encoder/decoder on the GPU. Secondly the “lossless” we obtain at the maximum quality is still the result of a YUV color-space conversion. This color-space conversion includes a down-sampling making highly-contrasted foreground/background combinations visually blurry. To solve this we need an additional RGB pass. This additional pass is not ready for the prime-time and we had to disable it in the 4.1 release.

    #2605
    mebbe
    Participant

    Yes, I have always had those two checkboxes marked (“Disable network-adaptive” and “Disable multi-pass”) and always have the slider on ‘max quality’. Strange thing is that with 4.1.29 I do not see the slow pass that slowly renders the fonts into pixel-perfectness (my first post was based on 4.1.28). Colored fonts with high-contrast combinations are now always a bit blurry. Black text on white background always has been perfect though.

    Anyway, I understand that this is a tricky area and thanks for your explanations. I cross my fingers that the additional RGB-pass will solve things and make it into the product some time soon 🙂

     

     

    #2665
    snejok
    Participant

    Hello all!

     

    As I understood:

    – Lightweight mode works as NX 3.5?

    – Lightweight mode must look like as virtual session in NX 3.5?

    – Fonts must look like 3.5 too?

     

    I don’t see any difference between “normal NX4.1” and “lightweight NX4.1” session.

    As I understand lightweight mode must show fonts perfectly as NX 3.5 does.

     

    P.S. how can I check on client side that lightweight mode enabled? I only see that codec is “Unknown” in lightweight mode 🙂

    Attachments:
    #2703
    abo
    Participant

    Hi,

    I have a similar problem. I have set “Link quality” to 9, “Image encoding quality” to 9, “Disable multi-pass display encoding” to “true” and “Disable network-adaptive quality” to “true”. If I have a Libreoffice document where text has green background and yellowish font-color with strike-through, it becomes quite blurry and practically unreadable.

    Are there any settings I might be able to change that would fix this?

    #2713
    fra81
    Moderator

    Hi.

    You can use lightweight mode to have pixel-perfect fonts, but only if you are running virtual sessions.It can be enabled in the Server preferences -> Performance tab, accessible by clicking on the “Show the server status” button of the tray icon on the server (or by editing the “AgentLightweightMode” key in the ‘/usr/NX/etc/node.cfg’ file).

    As explained by titan in the post above, work is in progress to provide a lossless RGB mode in all types of session.

    #2730
    abo
    Participant

    Hi,

    I have tried enabling Lightweight mode, but it did not fix the problem. Hopefully a lossless RGB-mode sometime in the future will fix this.

    #2734
    Britgirl
    Keymaster

    @snejok, check this article: https://www.nomachine.com/AR02L00779 for more info about lightweight mode.

    #2867
    snejok
    Participant

    @Britgirl, could you say something about this?

    P.S. how can I check on client side that lightweight mode enabled? I only see that codec is “Unknown” in lightweight mode

    #2879
    Britgirl
    Keymaster

    @snejok, “unknown” indicates it’s using lightweight. We couldn’t write “Codec lightweight” since lightweight is not a codec. In 4.2, ‘Unknown’ won’t be used at all, and only if a specific codec is being used will we show this info.

Viewing 12 posts - 1 through 12 (of 12 total)

This topic was marked as solved, you can't post.