Plain vanilla install: client authentication failure

Forums / NoMachine for Linux / Plain vanilla install: client authentication failure

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #1500
    Brice
    Participant

    Hi guys,

    I have 2 questions:

    I am using currently nxserver 3.5 without problem on OpenSuse 12.1 with a windows 7 client.

    I am in the process of upgrading my Linux OS so Opensuse 12.3.

    NoMachine Version: 4.0.368-1
    OpenSuse 12.3 (3.7.10-1.16-desktop x86_64)

    So I fired a test machine and tried. I rmp’ed -i the distribution rpm file:

    rpm -i nomachine_4.0.368_1_x86_64.rpm
    NX> 700 Starting install at: Wed Jan 01 16:50:17 2014.
    NX> 700 Installing: nxclient version: 4.0.368.
    NX> 700 Using installation profile: SUSE.
    NX> 700 Install log is: /usr/NX/var/log/nxinstall.log.
    NX> 700 Compiling the USB module.
    NX> 700 Installing: nxplayer version: 4.0.368.
    NX> 700 Using installation profile: SUSE.
    NX> 700 Install log is: /usr/NX/var/log/nxinstall.log.
    NX> 700 Installing: nxnode version: 4.0.368.
    NX> 700 Using installation profile: SUSE.
    NX> 700 Install log is: /usr/NX/var/log/nxinstall.log.
    NX> 700 Creating configuration in: /usr/NX/etc/node.cfg.
    NX> 700 Installing: nxserver version: 4.0.368.
    NX> 700 Using installation profile: SUSE.
    NX> 700 Install log is: /usr/NX/var/log/nxinstall.log.
    NX> 700 Creating configuration in: /usr/NX/etc/server.cfg.
    NX> 700 Install completed at: Wed Jan 01 16:51:31 2014.
    NX> 700 NoMachine was configured to run the following service:
    NX> 700 NX service on port: 4000

    All good.

    Now on the client side I get:

    NX> 203 NXSSH running with pid: 5512
    NX> 285 Enabling check on switch command
    NX> 285 Enabling skip of SSH config files
    NX> 285 Setting the preferred NX options
    NX> 200 Connected to address: 192.168.1.103 on port: 22
    NX> 202 Authenticating user: nx
    NX> 208 Using auth method: publickey
    NX> 204 Authentication failed.

    I googled the problem and tried the ssh_config trick but it didn’t help.

    The only thing I noted was in the nx home directory (/var/NX/nx), I don’t have any .ssh/authorized_keys2 or .ssh/authorized_keys.

    Any ideas ?

    My second question is regarding NIS. I am using a NIS nx user for the current 3.5 install base and the definition of the user is different for the version 4.0.

    Is there any way I can make a single NIS nx user for both distribution 3.5 and 4.0 ?

    Thanks

    Brice.

     

    #1526
    Britgirl
    Keymaster

    Brice, if you are using a client 4 to connect to your new server 4 you need to make sure that connect using the ‘NX’ protocol. It appears that you are trying to connect via SSH and the free NoMachine for Linux does not support SSH connections. Steps on how to do this are here: https://www.nomachine.com/AR12K00759.

     

    #1541
    Brice
    Participant

    Hi,

    Thanks for your answer. I followed instruction provided to connect to a server 4 with a client 4 using the NX protocol.

    I got a “No available sessions in this server” error message.

    No errors in the NX logs, just info:

    ndx.log:
    Info: Connection from 192.168.1.54 port 50656 accepted on Fri Jan  3 13:53:53 2014.
    Info: Connection from 192.168.1.54 port 50656 process 24425 started on Fri Jan  3 13:53:53 2014.

    nxerror.log:
    Info: Handler started with pid 24425 on Fri Jan  3 13:53:55 2014.
    Info: Handling connection from 192.168.1.54 port 50656 on Fri Jan  3 13:53:55 2014.

    nxserver.log:
    13:54:02:398.145 NXSERVER-4.0.368[24425] User ‘xxxxx’ logged in from ‘192.168.1.54’.

    So no critical error is happening. But I did not define any users in the NX configuration, as in 3.5.

    Did I miss a step and should pre-define users? Please note that this is a NIS’ed user, but this works perfectly with 3.5.

    Thank you

    B.

     

    #1856
    reza
    Moderator

    Is your server configured to run X? If so, then what login Window is it: GDM, KDM…? Additionally, what desktop session is it: Gnome, KDE…?
    If you are looking to run a virtual desktop session (i.e you want a terminal server), then you should consider the Workstation.

    • This reply was modified 7 years, 8 months ago by reza.
Viewing 4 posts - 1 through 4 (of 4 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.