Poor client performance on macOS 11.0 Big Sur?

Forums / NoMachine for Mac / Poor client performance on macOS 11.0 Big Sur?

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #29988
    AvatarBleo
    Participant

    Hello,

    I recently installed NoMachine workstation on a Ubuntu 20.04 host and have been testing client performance in Windows 10 and macOS 11 Big Sur (2018 Core i7 Macbook Pro). The Windows client performance is astonishing, i’m truly impressed. In MacOs however the performance is quite poor with a noticeable amount of latency under the same test conditions (under windows its feels like using a native desktop, MacOS feels like VNC over wan connection). I’m not sure if h264 hardware decoding is being used on the Mac, i suspect it is not due to high cpu utilization and poor performance. I have disabled various settings under the display options on the Mac client and that has increased performance/decreased latency over default but i’ve run out of check boxes to play with. Please let me know if there is any helpful logs/info I can provide.

    #30060
    AvatarTor
    Contributor

    Hi, sorry for the late reply.
    We’ve optimized as best as we could the rendering with CoreGraphics, but the high frame rate on high DPI monitors stresses a bit the CPU. We’re aware of it and we’re working on this:

    https://www.nomachine.com/FR06O03452

    You could disable client side post-processing and/or multi-pass display encoding to reduce the CPU usage.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.