Poor performance when host screen is off

Forums / NoMachine for Linux / Poor performance when host screen is off

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #35529
    korst1k
    Participant

    Hi guys,

    I’m faced with exactly the same problem, as https://forums.nomachine.com/topic/poor-performance-lag-when-host-screen-is-off
    It’s really annoying bug. FR for this: https://knowledgebase.nomachine.com/FR03S04105
    Unfortunately, priority for this task currently is Low.
    It is possible to raise priority for this feature request in the near future?
    Thanks.

    #35537
    korst1k
    Participant

    Also, I found the following topic: https://forums.nomachine.com/topic/nomachine-time-lag-after-remote-computer-inactivity-lock-screen-2
    And it fully represents my problem.
    Workaround for my problem the same: changing the resolution of the server and restoring it back is solving the issue.
    How to reproduce:
    1. connect to the server (monitors are off in this moment)
    2. after connection is established performance will be slow until step 4
    3. running xset q and got the following output:

    user@home:~$ xset q
    Keyboard Control: auto repeat:  off    key click percent:  0    LED mask:  00000002
    XKB indicators: 00: Caps Lock:   off    01: Num Lock:    on     02: Scroll Lock: off
    03: Compose:     off    04: Kana:        off    05: Sleep:       off
    06: Suspend:     off    07: Mute:        off    08: Misc:        off
    09: Mail:        off    10: Charging:    off    11: Shift Lock:  off
    12: Group 2:     off    13: Mouse Keys:  off
    auto repeat delay:  500    repeat rate:  20
    auto repeating keys:  00ffffffdffffbbf        fadfffefffedffff     9fffffffffffffff    fff7ffffffffffff
    bell percent:  50    bell pitch:  400    bell duration:  100
    Pointer Control: acceleration:  2/1    threshold:  4
    Screen Saver: prefer blanking:  no    allow exposures:  no
    timeout:  300    cycle:  300
    Colors: default colormap:  0x20    BlackPixel:  0x0    WhitePixel:  0xffffff
    Font Path: /usr/share/fonts/X11/misc,/usr/share/fonts/X11/Type1,built-ins
    DPMS (Energy Star): Standby: 1200    Suspend: 0    Off: 0
    DPMS is Enabled

      Monitor is Off

    4. Changing the resolution of the server and restoring it back – performance is normal now.
    5. running xset q again and got the next output:

    user@home:~$ xset q
    Keyboard Control: auto repeat:  off    key click percent:  0    LED mask:  00000002
    XKB indicators: 00: Caps Lock:   off    01: Num Lock:    on     02: Scroll Lock: off
    03: Compose:     off    04: Kana:        off    05: Sleep:       off
    06: Suspend:     off    07: Mute:        off    08: Misc:        off
    09: Mail:        off    10: Charging:    off    11: Shift Lock:  off
    12: Group 2:     off    13: Mouse Keys:  off
    auto repeat delay:  500    repeat rate:  20
    auto repeating keys:  00ffffffdffffbbf   fadfffefffedffff    9fffffffffffffff  fff7ffffffffffff
    bell percent:  50    bell pitch:  400    bell duration:  100
    Pointer Control: acceleration:  2/1    threshold:  4
    Screen Saver:  prefer blanking:  no    allow exposures:  no
    timeout:  300    cycle:  300
    Colors: default colormap:  0x20    BlackPixel:  0x0    WhitePixel:  0xffffff
    Font Path: /usr/share/fonts/X11/misc,/usr/share/fonts/X11/Type1,built-ins
    DPMS (Energy Star): Standby: 1200    Suspend: 0    Off: 0
    DPMS is Enabled

      Monitor is On

    OS: Xubuntu 20.04.3 LTS with XFCE 4.14
    It will be very good if this problem will be fixed in the near future.

    Thanks guys.

    #35654
    Carin
    Participant

    Hi korst1,

    Indeed, this feature request https://knowledgebase.nomachine.com/FR03S04105  will solve the problem that you’re facing. This is going to be implemented in the next software major release V8.

    You can follow the latest NM software updates here: https://knowledgebase.nomachine.com/software-updates.

    Thank you for sharing your use case with us.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.