Port forwarding issue

Forums / NoMachine for Linux / Port forwarding issue

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #17453
    Andrew-
    Participant

    Hi all,

    I am very new at this, so bear with me please.

    I’ve got 2 laptop, both linux mint. I’ve successfully port forwarded laptop 1 on port 4000

    The router wont let me port forward to port 4000 as it sees it a conflict.  So I port forwarded it to 4001.

    Error 111, connection refused. So I tried 5000. No go.

    Is there a bug in NoMachine that it seems only to want to work on 4000? Or am I missing something?

    thanks

    #17461
    kroy
    Contributor

    If you are using NoMachine to connect inside Local Area Network, port forwarding isn’t required. If you want to connect over the network (WAN), you can enable UPnP port mapping (https://www.nomachine.com/AR11L00827) or open ports manually, which you already started.

    As it appears from your entry – there was port conflict because port 4000 was already opened for laptop 1. For laptop 2 you need to open another unoccupied port like 4001. But you need additionally to change NX port on NoMachine server settings on that machine.

    There is two methods to do it. Via User Interface (Server preferences -> Network services -> Edit) or the server configuration file (edit /usr/NX/etc/server.cfg file and uncomment “NXPort 4000” line and change 4000 to 4001). After changes you need to restart nxserver (sudo /usr/NX/bin/nxserver –restart). More info you can find there: https://www.nomachine.com/AR01L00770.

Viewing 2 posts - 1 through 2 (of 2 total)

This topic was marked as solved, you can't post.