Portal server could not retrieve source node

Forums / NoMachine Cloud Server Products / Portal server could not retrieve source node

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #255
    Avatarmolko
    Participant

    I’m testung nomachine portal server with a nomachine workstation node on linux
    It’s not possible to add the node correctly

    portal server :
    root@nxportal:/usr/NX/bin# ./nxserver –nodeadd nxnode1
    NX> 763 Could not authenticate on the remote node using servers public key.
    NX> 763 Would you like to login on remote node as a privileged user to add
    NX> 763 this key and try again? [yes|no]: yes
    NX> 765 Username: root
    NX> 766 Password:
    NX> 104 Cannot retrieve resource list from the node.
    NX> 104 Warning: Node type S cannot be a node of server type PSE.
    NX> 104 Warning: Node will be not accessible in the multi-node environment.
    NX> 104 Adding node: nxnode1 with port: 4000
    NX> 104 With protocol: NX
    NX> 104 With connection type: encrypted
    NX> 104 With load-balancing: yes
    NX> 104 With type: NX
    NX> 104 With weight:
    NX> 104 With limit:
    NX> 104 With distribution:
    NX> 104 With operation system:
    NX> 104 With product:
    NX> 104 With cpu:
    NX> 104 With hardware:
    NX> 104 Session types available on node:
    NX> 104 Services denied on node: none
    NX> 104 Node platform:

    Settinsg on the nxnode

    root@nxnode1:/usr/NX/etc# cat server.cfg |grep InstallationType
    InstallationType node

    root@nxnode1:/usr/NX/etc# cat server.cfg |grep AvailableSessionTypes
    AvailableSessionTypes unix-xsession-default,unix-gnome,unix-kde,unix-xdm,windows

    root@nxnode1:/usr/NX/etc# cat server.cfg |grep VirtualDesktopSharing
    VirtualDesktopSharing 1

    #256
    Avatarsil04
    Keymaster

    Hi Molko,
    I suspect that installation on the node is NoMachine and not Workstation. Can you please check by running there nxserver –version? If it’s NoMachine, I think you have to uninstall it, remove the installation directory, and install the Workstation again.
    I hope this help 🙂

    #260
    Avatarmolko
    Participant

    Hi

    for all:

    the key point was “remove the installation directory”. I have first tested the nomachine package on the node and then installed the enterprise package after uninstall the nomachine package with “apt-get purge nomachine”. You must additional delete the installation directory (the etc directory in NX) otherwise nomachine bears the old version status in mind.


    @sil04
    : thanks for the hint

Viewing 3 posts - 1 through 3 (of 3 total)

This topic was marked as closed, you can't post.