Possible settings bug in 4.3.24

Forums / General Discussions / Possible settings bug in 4.3.24

Tagged: , ,

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #5017
    Avatarheywood
    Participant

    I have several client machines sitting on a LAN behind a router. All clients are running NX 4.3.24 (some on MacOS 10.8+10.9, some on Ubuntu 12.04). On the router, I have individual pairs of TCP/UDP ports forwarded to the LAN-side client IPs, for example:

    1.2.3.4:60000 (router WAN IP:port) –> 192.168.1.101:4000 (client #1 LAN IP:port), TCP only
    1.2.3.4:60001 (router WAN IP:port) –> 192.168.1.101:4191 (client #1 LAN IP:port), UDP only
    1.2.3.4:60002 (router WAN IP:port) –> 192.168.1.102:4000 (client #2 LAN IP:port), TCP only
    1.2.3.4:60003 (router WAN IP:port) –> 192.168.1.102:4191 (client #2 LAN IP:port), UDP only

    My idea with this was to be able to connect from my admin machine (running NX 4.3.24 in host mode; MacOS 10.6) to individual clients, one at a time, by defining each client as a separate connection in NX’s “connections” interface with the appropriate ports.

    The issue I’m seeing is that while the host port (TCP) settings for multiple clients can be set individually as expected, changing the UDP port for any one client causes that port number to be assigned to all the other clients as well.

    I suppose I could just disable the “Use UDP communication for multimedia data” checkbox for each defined client (under Advanced), but it seems like the behaviour I’m seeing may not be what is intended. Any clarifications would be very much appreciated.

    -H

    #5145
    AvatarTor
    Contributor

    Hi heywood.

    When the client starts the first time, it selects a free port in a range defined in settings and tries to always use the same, in order to ease the firewall configuration and match the UDP rules.
    When there are multiple instances running, each client using UDP selects a new port in the range instead of the “default” port. You can change both the default port and the range in Edit => Advanced => UDP settings (visible only if NX protocol is selected).

    You should only need to configure your router to open the range of selected ports.

    #5179
    Avatarheywood
    Participant

    Hi Tor,

    My point was that if I define two different connections within NX client, both to the same host IP (differing only by TCP port number), then go into Advanced > UDP settings and define the preferred UDP port on one connection, that change _also_ changes the preferred UDP port for the other connection. This is consistent with the second comment on this thread, but it seems counterintuitive to me (unless there’s a good technical reason for doing things this way).

    This obviously isn’t catastrophic — NX client falls back to trying all UDP ports in the defined range if the preferred port is busy upon initial connection — but it’s pretty counterintuitive that changing the setting for one defined connection should also change it for the others.

    In any case, I’ve now defined the same preferred UDP port, and the same fallback range, for both connections to avoid this issue, and forwarded the entire range through the router.

    Thanks,

    -H

Viewing 3 posts - 1 through 3 (of 3 total)

This topic was marked as solved, you can't post.