Possibly a bug on Mac client

Forums / NoMachine for Mac / Possibly a bug on Mac client

This topic contains 2 replies, has 2 voices, and was last updated by Avatar kvic 21 hours, 25 minutes ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #24223
    Avatar
    kvic
    Participant

    Hi there,

    I only heard about NoMachine recently and started experimenting with the free version. It grows on me everyday 🙂

    I run into one (or perhaps two) nuance and hope there is a quick fix.

     

    Both server & client are NoMachine 6.8.1. Both on macOS Mojave 10.14.6. Client machine has a Magic Trackpad and a mouse.

    Issue 1

    To reproduce:

    1. Set up a connection with “Grab the keyboard input” and “Grab the mouse input” checked.
      So that (I believe) almost all key inputs including e.g. Cmd-tab & Cmd-space are sent over to the server.
    2. Connect to server in full screen mode.
      So the remote desktop of the server is one Space on the client machine.
    3. Confirm Cmd-tab and Cmd-space indeed sent over to server
    4. Swipe /w four fingers on the Magic Trackpad on the client machine.
      This switches to a Space of the local desktop on the client machine.
    5. Swipe /w four fingers again back to the Space of the remote desktop.
    6. Left click on mouse to active key & mouse grab.
    7. Test Cmd-tab & Cmd-space. No longer sent over to the server.

    Temporary workaround: Press Ctrl-Option K twice to fully activate grab key inputs again.

    Related issue with a slightly modified workflow

    • Replace Step 4 /w Ctrl-Option M to minimise the remote desktop.
    • Replace Step 5 /w clicking NoMachine icon on the client’s Docker to go back to remote desktop.

    Issue: the client’s menu bar (active app NoMachine) at the top overlays the remote desktop.

    With the modified workflow, Issue 1 still persists.

    If it’s a user error, pls also let me know as I’m only into NoMachine for a few weeks.

    Cheers

    #24324
    Avatar
    Tor
    Contributor

    Hi. I’m sorry for the slow answer, we were checking your reports.

    Issue 1

    We’ve identified the problem and implemented a fix, it’ll be released shortly. You can track the fix here:
    https://www.nomachine.com/TR10Q09458

    Related issue with a slightly modified workflow

    This is a little bit more tricky. The problem is related to our fullscreen mode, which is not making use of Spaces and gets confused by a particular sequence of events, causing the menu bar to be visible. There is not an easy fix for this unluckily. Our development branch uses a correct fullscreen mode, but that patch is bound to some other changes that are not ready to be released in a short time. The only workaround consists in swipe-switching to the current NoMachine Space before clicking the Dock icon, or switching the Space when the menu bar is visible to hide it.

    #24492
    Avatar
    kvic
    Participant

    Just installed 6.8.2 (typing this message from it). So far the fix works flawlessly. It’s a huge relief for me personally & I hope it benefits other users suffering from the same issue.

    Thank you very much for the quick fix & being so helpful!

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.