Printer sharing working in Windows, not OS X?

Forums / NoMachine Cloud Server Products / Printer sharing working in Windows, not OS X?

Tagged: , ,

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #3362
    esarmien
    Participant

    Hi,

    We have the latest NoMachine Cloud Server 4.2.21-2 installed in a load balanced configuration.

    Our portal host, portal-1, connects to two nodes, rce6-1 and rce6-2 over SSH protocol. We have printer sharing enabled in–

    /usr/NX/etc/node.cfg

    with

    EnablePrinterSharing client

    [root@rce6-portal-1 esarmien]# /usr/NX/bin/nxserver –nodelist

    NX> 104 Node list:

    Status Connection Node Type LB Weight Limit Label

    ——- ———- ——————————- —- — —— —– —–

    running encrypted rce6-1.priv.hmdc.harvard.edu:22 NX yes

    running encrypted rce6-2.priv.hmdc.harvard.edu:22 NX yes

    [root@portal-1 esarmien]# /usr/NX/bin/nxserver –nodelist

    NX> 104 Node list:

    Status Connection Node Type LB Weight Limit Label

    ——- ———- ——————————- —- — —— —– —–

    running encrypted rce6-1:22 NX yes

    running encrypted rce6-2:22 NX yes

    – On OS X, attempting to share a printer and then print to it works to an extent. I am able to see the printer in NX session but when I print to it, I do not see any job sent to the queue and nothing is printed.

    – In Windows, printer sharing works perfectly.

    #3382
    adp
    Participant

    Hello.

    We confirmed that there is indeed a problem with printing when device is being shared from client on Mac OS. We’ve inserted a trouble report: https://www.nomachine.com/TR04L04395 .┬áThe fix for this issue will be included in the next update.

    • This reply was modified 7 years, 4 months ago by adp.
    #3538
    esarmien
    Participant

    I’m running 4.2.22_2 and I am still unable to print in OS X. Has this actually been fixed?

     

    Best,

    Evan

     

    #3568
    adp
    Participant

    Hello,

    Yes, this issue should be fixed in nomachine_4.2.22_1. Can you confirm that you have installed this version on both client and server machines? So that your Mac OS host is also running 4.2.22_1? If so, this is a new issue and something different than problem tracked by trouble report ‘TR04L04395’. It would be useful if you’d provide a little bit more info. To be precise:

    1) OS (with version) of the client machine.

    2) OS (with version) of the server machine.

    3) Where is the printer attached physically.

    4) Exact steps to reproduce the issue.

    Also it would be helpful if you could send compressed $HOME/.nx directories both from client and server side after reproducing the problem. Please note, that before collecting the logs you should make sure that they are not deleted after session ends. To do so please:

    – On server side edit the /usr/NX/etc/node.cfg file, uncomment the following key and set it to ‘0’:

    SessionLogClean 0

    – On client’s side, open the Player and go to ‘Prefferences’ -> ‘Appearance’ and check the “Don’t delete old log files on exit”.

    The logs may be too big to attach them on forum. In that case please send them to issues[at]nomachine[dot]com

    #3575
    esarmien
    Participant

    Hi ADP,

    Thanks for this. I updated my NoMachine client to the latest 4.2.22_2 and it worked. D’oh!

    Best,

    Evan

Viewing 5 posts - 1 through 5 (of 5 total)

This topic was marked as solved, you can't post.