Privilege of user account

Forums / NoMachine Terminal Server Products / Privilege of user account

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #29257
    AvatarAubert887
    Participant

    How to disable a NX user to shutdown a computer. In my case when a user open a session xfce4,  It could shutdown the computer using the terminal. How can I avoid this isssue?

    After that, when my session goes on standby mode, the Xsreensaver give this message: Xscreensaver Authentification failed

     

    Cordially,

    Thanx

    Attachments:
    #29281
    Avatargraywolf
    Moderator

    The first issue looks related to Xfce configuration.

    About the screensaver, please tell me the Linux distro in use.

    Is the Xfce session running on a NoMachine virtual desktop or on a physical display?

    #29282
    AvatarAubert887
    Participant

    I use Red Hat Linux (7.7). xfce4-session runing on NoMMachine terminal server Node. I have build a multi node. My broker turn on Nomachine Enterprise Terminal Server and my host turn with NoMachine Terminal Server Node. I use url web.

     

    #29393
    Avatarhawk
    Contributor

    Hello,
    NoMachine do not provide feature to block commands. You can do this by configuring sudoers file for example.
    http://www.tecmint.com/disable-shutdown-and-reboot-commands-in-linux/

    About xscreenserver problem we are unable to reproduce the problem. Please check if changing DefaultDesktopCommand key value in /usr/NX/etc/node.cfg (on server side) from “/usr/bin/startxfce4” to “dbus-launch /usr/bin/startxfce4” will fix the problem. You need to have root permissions to change values in NoMachine configuration files.

    If this will not help some logs may be helpful. Please run command sudo grep xscreensaver /var/log/secure* and send us output to forum[at]nomachine[dot]com, referencing the topic as subject.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.