Problem after 6.0 62 update

Forums / NoMachine for Mac / Problem after 6.0 62 update

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #16460
    BitPerfectRichard
    Participant

    I recently updated my NoMachine installations to the latest 6.0.62 incarnation, and as a result my Client (RMBP running macOS 10.13) cannot connect to my Server (Mac Mini running macOS 10.13.1).  The problem is reported as “Error is 60: Operation timed out”.   Log file(s) appended.

    I have rebooted both Client and Server, and the problem remains.

    #16559
    kroy
    Contributor

    Is the nxserver running? Problems shows after upgrade – right? Which product and version did you install there? Can you send logs also from server side? Please enable debug and restart nxserver (sudo /etc/NX/nxserver --restart) earlier. Instructions about debug and collecting logs you can find there: https://www.nomachine.com/DT07M00098.

    #16563
    BitPerfectRichard
    Participant

    Is it unreasonable of me to be upset that after 5 days and 12 hours nobody from the NoMachine support team has taken a look at this and so much as posted an acknowledgement of the issue?

    #16576
    Britgirl
    Keymaster

    It seems that Kroy replied to you as you yourself were following up and he forgot to mention that the logs you sent were only player logs from a session which wasn’t started (maybe you attached the wrong set, I dont’ know), so weren’t very helpful. So yes, we did see your topic, the day it came in, and it was placed in the queue,  but unfortunately the lack of information slowed down any potential investigation.

    Please understand that the forums are handled by the developers as quickly as possible – in the time they have between handling support tickets coming from subscribed customers and their own development work.

    You can send your logs to forum[at]nomachine[dot]com and we’ll take a look.

    #16606
    BitPerfectRichard
    Participant

    OK, I have followed the instructions on the KB page, and replicated the whole process.  I have attached both server side and client side logs.

    FYI, I had a lot of permissions issues in following the instructions, so I hope you won’t find yourselves burdened by permissions issues when it comes to reading them.  I’m not an expert in this stuff, so bear with me if I have gotten anything wrong.

    I also include a screenshot of the nx server status from the Client Side

    #16631
    kroy
    Contributor

    We received player logs from the connecting client side, and nxclient logs from the server side. We would also need also nxserver logs (it’s in /Library/Application\ Support/NoMachine/var/log/) on the server in order to see what could be wrong.

    #16634
    BitPerfectRichard
    Participant

    Here are the missing nxserver logs from the server side.

    Attachments:
    #16713
    kroy
    Contributor

    A deeper investigation would be required to understand what happens. If you prefer you can just uninstall and install NoMachine again on both machines – this should fix it.

    From the logs you attached the problem could be a wrong certificate on player side. To investigate problem we would need also all logs from /Library/Application\ Support/NoMachine/var/log/ from both sides and information about updates. Was systems updated after installing NoMachine 6.0.62?

    #16742
    BitPerfectRichard
    Participant

    Per your instructions, I uninstalled NoMachine from both machines, and re-installed it.  As you anticipated, this did indeed solve the problems.  I assume there is therefore no further need for me to send you the additional logs you requested.

    FYI, I believe the macOS 10.12 -> 10.13 update (and even the 10.13 -> 10.13.1 update) was done subsequent to updating NoMachine from the previous version to 6.0.62 but I can’t be 100% sure on that.  But given my experience to date with macOS 10.13 to date, it would not surprise me if it turned out that it was the culprit here.  Unfortunately, I am obliged to apply every OSX/macOS update as it it released, so I don’t have the ‘sensible’ option available.

    Thanks for your help, Kroy.

Viewing 9 posts - 1 through 9 (of 9 total)

This topic was marked as solved, you can't post.