Problems connecting to office PC from Windows 10 at home

Forums / NoMachine for Windows / Problems connecting to office PC from Windows 10 at home

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #25030
    Avataropticalinn
    Participant

    I am using latest  NoMachine free version 6.9.2.  I get timeout trying to connect my 2 PCs from home to office. I can connect from office to my home using standard setup.  I am trying port forwarding on port 400 without success. I have a Asus rt-68 router.  I verified with IPconfig that the IP address is correct.  I would still like to use this remote software from what I seen on the using it in the reverse direction.  What am I doing wrong

    #25048
    Avatarkroy
    Contributor

    Do you have enabled UPnP function on the office router? If yes – you should follow instructions from “Using NoMachine for remote access to a computer over the internet” section on the https://www.nomachine.com/getting-started-with-nomachine. If no – you should ask administrator of your office network to forward port manually.

    If you have permission to change your router configuration, you can just enable UPnP or forward port manually by passing traffic to port 4000 (NX protocol). Follow your router instruction to know how to do that (guide you can also find in the internet, for example from there: https://portforward.com/asus/rt-ac68p/).

    #25097
    Avataropticalinn
    Participant

    I did have UPnP enabled and tried port forward for my client PC IP address.  I cannot connect in either direction.

    #25116
    Avatarkroy
    Contributor

    I cannot connect in either direction.

    Something have broken, earlier you wrote that you could connect from office to home. Maybe IP was changed. Are you sure that you chose properly address?

    Additionally please verify if the IP address which you are trying to connect is indeed that machine public IP (for example there: https://www.whatismyip.com/). If not – it could indicates that you have a double NAT networking. Which means that NoMachine has to go through two or more routers. In that case you need to set up separate port forwarding rules on each device.

    It will be possible to skip these steps with NoMachine Network feature (https://www.nomachine.com/FR07J02731) which is coming soon.

Viewing 4 posts - 1 through 4 (of 4 total)

This topic was marked as solved, you can't post.