Problems on MacOSX if in an AD domain?

Forums / NoMachine for Mac / Problems on MacOSX if in an AD domain?

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #3594
    samo_dadela
    Participant

    1. Just installed it on MacOSX 10.7 (nx 4.2.22_1) . When the system is rebooted and I connect I get a black screen – can’t see the login screen.

    I then log in (at the console) and nx works.

    2. I wanted to disable the service and I get the credentials dialog. I entered my log-in credentials (I have admin) rights but it would not accept them. Tried: username/password, username@domain.com/password, DOMAIN\username/password.

    For 2. the problem might be that I’m joined into an AD domain.

    #3621
    adp
    Participant

    Hello,

    Regarding your second problem. Could you please give us the outputs of the following commands:

    sudo -V

    sudo -l -U <user>

    Could you also tell us how do you put credentials for su / sudo commands on this Mac? Is it in username/password or username@domain/password or DOMAIN\username/password format? It would be very helpful if, after reproducing the issue, you would send us /Library/Application Support/NoMachine/var/log/nxerror.log file. You can attach it to the forum post, or it it’s too big (it shouldn’t be) – send it to issues[at]nomachine[dot]com. Thank you.

    • This reply was modified 7 years, 4 months ago by adp.
    #3628
    fra81
    Moderator

    Please send the whole ‘/Library/Application Support/NoMachine/var/log/’. That will be useful also for the first problem.

    #3965
    samo_dadela
    Participant

    I installed 4.2.25 – the same happens.

    There is nothing being logged when the login fails in /Library/…NoMachine/var/log.

    I also trying to provide a local user with admin priviledges -> I’m unable to authenticate. I can’t change the connection preferences.

    #3967
    samo_dadela
    Participant

    $ sudo -V
    Sudo version 1.7.4p6a

    $ sudo -l -U samod
    Matching Defaults entries for samod on this host:
    env_reset, env_keep+=BLOCKSIZE, env_keep+=”COLORFGBG COLORTERM”,
    env_keep+=__CF_USER_TEXT_ENCODING, env_keep+=”CHARSET LANG LANGUAGE LC_ALL LC_COLLATE
    LC_CTYPE”, env_keep+=”LC_MESSAGES LC_MONETARY LC_NUMERIC LC_TIME”, env_keep+=”LINES COLUMNS”,
    env_keep+=LSCOLORS, env_keep+=SSH_AUTH_SOCK, env_keep+=TZ, env_keep+=”DISPLAY XAUTHORIZATION
    XAUTHORITY”, env_keep+=”EDITOR VISUAL”, env_keep+=”HOME MAIL”

    User samod may run the following commands on this host:
    (ALL) ALL
    (ALL) NOPASSWD: ALL

    /etc/sudoers:

    samod  ALL=(ALL) NOPASSWD: ALL

    When you join the mac to the domain, the user can use their short name. For example: samod@mydomain.com, then use samod. SSH will also accept samod@mydomain.com  as the username. However it’s better to use the short name.

    The mac is setup so, that when you first login as a domain user, an account is created.

    BTW: I’m still experiencing 1. in 2.2.25.

     

     

     

    #3996
    adp
    Participant

    Hello,

    You say that the first problem is still reproducible in 4.2.25. Is the second one also still present? If so – could you please send us compressed /Library/Application Support/NoMachine/var/log directory? You can attach it to the forum post, or it it’s too big – send it to issues[at]nomachine[dot]com.

    Thank you.

Viewing 6 posts - 1 through 6 (of 6 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.