Problems with IE11

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #22175
    Avatartermmachine
    Participant

    Hi, I am using NoMachine Terminal Server 6.6.8 (classic mjpeg codec) and our company forces to use Internet Explorer 11 (11.1087.16299.0). Our whole company uses the German keyboard layout. I found 2 keyboard problems and 2 screen problems.

    The first 2 problems (keyboard) have priority for me.

    1) In IE11 the Alt Gr combinations are faulty. Not all Alt Gr combinations are working. For example @,{,[,],} is ok, but | (pipe) and \ (backslash) doesnt work. On Firefox and Chrome everything works correctly.

    2) The NoMachine Webplayer auto decide the Keyboard-Layout. Sometimes the German detection works, for example the detection on remote ubuntu system (direct xdm query) is ok, but on my remote Solaris 10 system (xdm list) the detection does not work. It auto selects the US keyboard every time, so that my clients have to manually switch to German. Sometimes the layout also says German, but it is US and you have to choose German once again.

    3) If I have my webplayer session in fullscreen (chosen in webplayer) and then I switch the IE tabs in windows taskbar, the fullscreen exits and you cannot enable it again, unless you press Esc. On Firefox and Chrome the fullscreen doesnt exit.

    4) When using EnableWebPreconfiguration 1 it is not possible to “detach window” in webplayer, because it is forbidden.

    Please let me know what I can do for you, that we can solve the problems. Thanks!

    #22186
    AvatarShoti
    Contributor

    Hi termmachine,

    First of all, let me explain one thing, the panel where you can choose a keyboard layout is visible only in the case of old browsers, without ‘KeyboardEvent.code’ support. The ‘KeyboardEvent.code’ property represents a physical key on the keyboard (as opposed to the character generated by pressing the key). So when a browser doesn’t support this API for a fully-functional keyboard, we’re asking customers to select the same layout already set on their operating system. When it’s possible, we always strongly suggesting customers use a modern browser for the best experience in the web player.

    Point 1 : This problem is known to us and we’re working to fix it, please see more here : https://www.nomachine.com/TR02Q09132

    You have the option to be notified when this issue is fixed, you just have to click on “Notify me when the TR is closed.” and insert your email address.

    Point 2: The web player isn’t deciding the keyboard layout, we just saving user’s choice in browsers cookie and for second connection web player uses the saved value, so for a very first connection (when the cookie is clean) by default chosen layout is the ‘US’ always. Maybe you mean something else?

    Point 3: How are you switching tabs? Using a ‘Ctrl + Tab’ combination? This can be out of scope and not possible to fix, as it’s implemented at the browser level, but we’ll check what can we do here, as a workaround you can go to fullscreen using the F11 key and problem should be eliminated after that.

    Point 4: We disable the “detach window”  when the browser runs in a fullscreen mode, can you please check that this is not the problem? We weren’t able to reproduce any issue with ‘EnableWebPreconfiguration’ key

    #22191
    Avatartermmachine
    Participant

    Hi, thanks for your answer!

    Point 1: Thanks, I registered my mail for notify.

    Point 2: Ah ok thanks for clarification. I tried the following:
    In IE11 I cleared all browser data (cookies cache everything), restarted the browser, and you are right. On first solaris 10 xdm session initiation, the keyboard was US on the solaris login screen. I switched it to german, works well after that. Then I reopenend the IE11, initiated the same xdm solaris 10 session again, and on login screen the keyboard showed German in NoMachine webplayer, but nevertheless it has the US mapping. I have to switch from German to another language and switch back to German. Only after this I have the German keyboard mapping.

    Point 3: Ctrl+Tab works fine. I mean if you have more Tabs in Internet Explorer opened and you switch between the IE-Tabs with Windows Taskbar previews (Mouseover IE icon in taskbar and switch between opened IE tabs). This setting in windows is called “show previews for individual tabs in the taskbar” in tabbed browsing settings (only then you see the opened IE tabs in taskbar). Here the fullscreen closes and cannot be opened again, unless you press Esc in IE. But I also think this is not fixable (due to browser level).

    Point 4: Yes, when in fullscreen the “detach window” is disabled. Its ok. But when not in fullscreen and press the “detach window” button, the new window opens but shows the error message, that NoMachine is configured to only accept connections via .nxs-file.
    This is the same error message as if I set “EnableWebPreconfiguration” to 1 and go to http://IPofServer:4080/nxwebplayer

    Thanks,
    Yours termi

    #22349
    AvatarShoti
    Contributor

    termmachine,

    We were not able to reproduce point 2 and 3 in our labs, we would need the logs from the client-side. Please find the instructions here how to gather web session logs: https://www.nomachine.com/DT10O00163#2.6 You can send them to forum[at]nomachine[dot]com.

Viewing 4 posts - 1 through 4 (of 4 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.